summaryrefslogtreecommitdiffstats
path: root/core/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-11-14 16:00:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-11-14 16:00:48 +0000
commite0b24e3a1182cd6c8ef4e629b3ef256bc39c8341 (patch)
tree1513ccc96f05a9316b137e6ddb976f8b809da0bd /core/abuild
parent403ccb271c7ec0d7c48a4c25895686096005a71a (diff)
downloadaports-e0b24e3a1182cd6c8ef4e629b3ef256bc39c8341.tar.bz2
aports-e0b24e3a1182cd6c8ef4e629b3ef256bc39c8341.tar.xz
core/abuild: fit annoying bug in doc()
Diffstat (limited to 'core/abuild')
-rw-r--r--core/abuild/APKBUILD10
-rw-r--r--core/abuild/find-name.patch11
2 files changed, 18 insertions, 3 deletions
diff --git a/core/abuild/APKBUILD b/core/abuild/APKBUILD
index ff532ab7..ad0e1f0f 100644
--- a/core/abuild/APKBUILD
+++ b/core/abuild/APKBUILD
@@ -1,14 +1,18 @@
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
pkgver=0.8.1
-pkgrel=0
+pkgrel=1
url=http://dev.alpinelinux.org/cgit/cgit.cgi/abuild/
-source="http://dev.alpinelinux.org/cgit/cgit.cgi/abuild/snapshot/abuild-$pkgver.tar.bz2"
+source="http://dev.alpinelinux.org/cgit/cgit.cgi/abuild/snapshot/abuild-$pkgver.tar.bz2
+ find-name.patch
+ "
depends="fakeroot"
license=GPL-2
build() {
cd "$srcdir/$pkgname"
+ patch -p1 -i ../find-name.patch
make install DESTDIR="$pkgdir"
}
-md5sums="a553a659b56ae077f595a5b8fbe6ee6d abuild-0.8.1.tar.bz2"
+md5sums="a553a659b56ae077f595a5b8fbe6ee6d abuild-0.8.1.tar.bz2
+1ab10a95f47ee7303a650c3f719a01b7 find-name.patch"
diff --git a/core/abuild/find-name.patch b/core/abuild/find-name.patch
new file mode 100644
index 00000000..8879d962
--- /dev/null
+++ b/core/abuild/find-name.patch
@@ -0,0 +1,11 @@
+--- abuild/abuild.orig Fri Nov 14 15:54:17 2008
++++ abuild/abuild Fri Nov 14 15:55:05 2008
+@@ -315,7 +315,7 @@
+ rm -f "$subpkgdir/usr/share/info/dir"
+
+ # compress info and man pages
+- find "$subpkgdir/usr/share" \( -name '*.info' -o name '*.info-[1-9]' \
++ find "$subpkgdir/usr/share" \( -name '*.info' -o -name '*.info-[1-9]' \
+ -o -name '*.[1-9]' \) -exec gzip {} \;
+
+ # remove if empty, ignore error (not empty)