summaryrefslogtreecommitdiffstats
path: root/core/bbsuid
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-01-28 08:39:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-01-28 08:39:54 +0000
commit7cebf0b6672c6089257011039dcf78a3816c2f9e (patch)
treea30f1660cdd77871aff457aff1a6eefa6c2fa912 /core/bbsuid
parent008f639d0ec7fb7342a815b37d42b0b3af61871f (diff)
downloadaports-7cebf0b6672c6089257011039dcf78a3816c2f9e.tar.bz2
aports-7cebf0b6672c6089257011039dcf78a3816c2f9e.tar.xz
core/bbsuid: added post_deinstall action
needed to restore busybox links after uninstall.
Diffstat (limited to 'core/bbsuid')
-rw-r--r--core/bbsuid/APKBUILD13
-rw-r--r--core/bbsuid/bbsuid.install6
2 files changed, 14 insertions, 5 deletions
diff --git a/core/bbsuid/APKBUILD b/core/bbsuid/APKBUILD
index 14be0ab4..380ceca6 100644
--- a/core/bbsuid/APKBUILD
+++ b/core/bbsuid/APKBUILD
@@ -1,13 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bbsuid
pkgver=0.2
-pkgrel=0
+pkgrel=1
pkgdesc="Busybox SUID root application wrapper"
-url="http://dev.alpinelinux.org/alpine/bbsuid"
+url="http://dev.alpinelinux.org/cgit/cgit.cgi/bbsuid"
license="GPL-2"
depends="uclibc busybox"
-source="http://dev.alpinelinux.org/alpine/bbsuid/$pkgname-$pkgver.tar.bz2"
-source="http://dev.alpinelinux.org/cgit/cgit.cgi/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
+install="$pkgname.install"
+source="http://dev.alpinelinux.org/cgit/cgit.cgi/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ $install"
+
build() {
cd "$srcdir/$pkgname"
@@ -15,4 +17,5 @@ build() {
make install DESTDIR="$pkgdir"
}
-md5sums="95e5dfe96d03e8b29405f699f8fb4698 bbsuid-0.2.tar.bz2"
+md5sums="95e5dfe96d03e8b29405f699f8fb4698 bbsuid-0.2.tar.bz2
+63cdf4583deb872ef1db16e1c941ce55 bbsuid.install"
diff --git a/core/bbsuid/bbsuid.install b/core/bbsuid/bbsuid.install
new file mode 100644
index 00000000..6ba7216f
--- /dev/null
+++ b/core/bbsuid/bbsuid.install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+case "$1" in
+ post_deinstall) busybox --install -s;;
+esac
+exit 0