summaryrefslogtreecommitdiffstats
path: root/core/beecrypt/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-11-24 16:48:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-11-24 16:48:36 +0000
commit36b7d352a71fcb43221c3c834ba94383d4f989b1 (patch)
tree5c51464fd48f9310c5b790bb94cf0f0f7f1c48d9 /core/beecrypt/APKBUILD
parente58727a80bd922a9c341a9669d17ca7ef1b0e5af (diff)
downloadaports-36b7d352a71fcb43221c3c834ba94383d4f989b1.tar.bz2
aports-36b7d352a71fcb43221c3c834ba94383d4f989b1.tar.xz
core/beecrypt: new aport
Diffstat (limited to 'core/beecrypt/APKBUILD')
-rw-r--r--core/beecrypt/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/core/beecrypt/APKBUILD b/core/beecrypt/APKBUILD
new file mode 100644
index 00000000..77f0b2a0
--- /dev/null
+++ b/core/beecrypt/APKBUILD
@@ -0,0 +1,25 @@
+#!/bin/sh
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=beecrypt
+pkgver=4.1.2
+pkgdesc="general-purpose cryptography library"
+url="http://sourceforge.net/projects/beecrypt"
+license="LGPL"
+depends=uclibc
+subpackages="$pkgname-dev"
+source=http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-threads \
+ --enable-shared \
+ --without-java \
+ --without-python \
+ --without-cplusplus
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums="820d26437843ab0a6a8a5151a73a657c beecrypt-4.1.2.tar.gz"