summaryrefslogtreecommitdiffstats
path: root/core/cramfs
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-01-02 22:07:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-01-02 22:07:23 +0000
commit793a3d586d95578767b7b1249217c11c9f828813 (patch)
tree2d3a094ca88b698516b867ce836648b22f36fda6 /core/cramfs
parentd2058638588144634feaf0154c979e01c19d3dcd (diff)
downloadaports-793a3d586d95578767b7b1249217c11c9f828813.tar.bz2
aports-793a3d586d95578767b7b1249217c11c9f828813.tar.xz
core/cramfs: new aport
Diffstat (limited to 'core/cramfs')
-rw-r--r--core/cramfs/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/core/cramfs/APKBUILD b/core/cramfs/APKBUILD
new file mode 100644
index 00000000..e40e57c2
--- /dev/null
+++ b/core/cramfs/APKBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Natanael Copa <natanael.copa@gmail.com>
+pkgname=cramfs
+pkgver=1.1
+pkgrel=0
+pkgdesc="Linux filesystem designed to be simple, small, and to compress things well"
+arch=""
+url="http://sourceforge.net/projects/cramfs/"
+license='GPL'
+depends="uclibc zlib"
+makedepends="zlib-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make CFLAGS="$CFLAGS" || return 1
+ install -d "$pkgdir"/sbin
+ install mkcramfs cramfsck "$pkgdir"/sbin
+}
+
+md5sums="d3912b9f7bf745fbfea68f6a9b9de30f cramfs-1.1.tar.gz"