summaryrefslogtreecommitdiffstats
path: root/core/fakeroot/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-11-04 14:41:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-11-04 14:41:04 +0000
commit5f11f909dbb20c7d4b7a530027bdb2cc43f15055 (patch)
tree252292c6072a0e3aec469709821afb19b76cb408 /core/fakeroot/APKBUILD
parenteec0548cff45a33465918f52ec257d7f1c0754ce (diff)
downloadaports-5f11f909dbb20c7d4b7a530027bdb2cc43f15055.tar.bz2
aports-5f11f909dbb20c7d4b7a530027bdb2cc43f15055.tar.xz
patch for fakeroot so we dont get ugly output from getopt
Diffstat (limited to 'core/fakeroot/APKBUILD')
-rw-r--r--core/fakeroot/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/core/fakeroot/APKBUILD b/core/fakeroot/APKBUILD
index c2f8607e..f08e5d0c 100644
--- a/core/fakeroot/APKBUILD
+++ b/core/fakeroot/APKBUILD
@@ -6,10 +6,13 @@ license='GPL'
url="http://packages.debian.org/fakeroot"
depends='uclibc'
makedepends='binutils gcc make linux-headers uclibc-dev'
-source=http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.tar.gz
+subpackages="dev doc"
+source="http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.tar.gz
+ getopt.patch"
build() {
cd $startdir/src/$pkgname-$pkgver
+ patch -p1 < ../getopt.patch
./configure --prefix=/usr #--libdir=/usr/lib/libfakeroot
make || return 1
make DESTDIR=$startdir/pkg install