summaryrefslogtreecommitdiffstats
path: root/core/make
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-11-06 20:50:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-11-06 20:50:31 +0000
commit755e79ef0ea234323c8faae3891283785dca0624 (patch)
tree4450cc53bcc7d5624e5d4e39a41935d54690e29c /core/make
parent99752a7e5dcd4c6c274fba68f5053b50be3dc80e (diff)
downloadaports-755e79ef0ea234323c8faae3891283785dca0624.tar.bz2
aports-755e79ef0ea234323c8faae3891283785dca0624.tar.xz
core/make: create doc package
Diffstat (limited to 'core/make')
-rw-r--r--core/make/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/core/make/APKBUILD b/core/make/APKBUILD
index e1635887..f3ef6d9e 100644
--- a/core/make/APKBUILD
+++ b/core/make/APKBUILD
@@ -6,11 +6,15 @@ pkgdesc="GNU make utility to maintain groups of programs"
url="http://www.gnu.org/software/make"
license=GPL
depends=uclibc
+subpackages="$pkgname-doc"
+splitfuncs="doc"
source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
build() {
cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
make || return 1
make DESTDIR="$pkgdir" install
}