summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-13 09:51:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-13 09:51:34 +0000
commit0837a73950a2461c249c24e1d2ec5e8bdcdedf52 (patch)
treead859f315ab779188a18c7959d321579dfce0dd3 /core
parent8afe14323eecd84ed146fe7afbe13176ba595fbd (diff)
downloadaports-0837a73950a2461c249c24e1d2ec5e8bdcdedf52.tar.bz2
aports-0837a73950a2461c249c24e1d2ec5e8bdcdedf52.tar.xz
core/file: upgrade to 5.00
disabled useless check for C++ while there
Diffstat (limited to 'core')
-rw-r--r--core/file/APKBUILD19
-rw-r--r--core/file/nocxx.patch15
2 files changed, 26 insertions, 8 deletions
diff --git a/core/file/APKBUILD b/core/file/APKBUILD
index a7fd0ffb..50b9b8e6 100644
--- a/core/file/APKBUILD
+++ b/core/file/APKBUILD
@@ -1,19 +1,22 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=file
-pkgver=4.26
-pkgrel=1
+pkgver=5.00
+pkgrel=0
pkgdesc="File type identification utility"
url="http://www.darwinsys.com/file/"
license="custom"
depends="uclibc zlib"
-source="ftp://ftp.astron.com/pub/file/file-4.26.tar.gz"
+source="ftp://ftp.astron.com/pub/file/file-$pkgver.tar.gz
+ nocxx.patch"
subpackages="$pkgname-dev $pkgname-doc"
build ()
{
- cd ${srcdir}/$pkgname-$pkgver;
- ./configure --prefix=/usr --datadir=/usr/share/misc;
- make || return 1;
- make DESTDIR=${pkgdir} install;
+ cd "$srcdir"/$pkgname-$pkgver
+ patch configure < ../nocxx.patch || return 1
+ ./configure --prefix=/usr --datadir=/usr/share/misc
+ make || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="74cd5466416136da30a4e69f74dbc7a0 file-4.26.tar.gz"
+md5sums="fd0b4ce55a756151629e06eaa3411e0c file-5.00.tar.gz
+28513788ba4d556ccd538867dc6205ab nocxx.patch"
diff --git a/core/file/nocxx.patch b/core/file/nocxx.patch
new file mode 100644
index 00000000..beb1ab90
--- /dev/null
+++ b/core/file/nocxx.patch
@@ -0,0 +1,15 @@
+--- a/configure 2004-12-07 21:34:23.205172545 +0000
++++ b/configure 2004-12-07 21:37:17.726654782 +0000
+@@ -5148,10 +5148,8 @@
+ :
+ else
+ { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&5;}
++ { echo "C++ sucks, ignoring ..." >&5; }; }
+ fi
+
+ ac_ext=cc