summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-27 09:24:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-27 09:24:47 +0000
commit2c349455d9ee5940f386ab42ef552c7a7f8311b8 (patch)
treeba348a3f8190357ad1a5322ba0e0c376de24f963 /core
parentc11c96ae5a8e35bf8f68ecb96ef044ab6bd87414 (diff)
downloadaports-2c349455d9ee5940f386ab42ef552c7a7f8311b8.tar.bz2
aports-2c349455d9ee5940f386ab42ef552c7a7f8311b8.tar.xz
core/busybox: include the /bin/sh link so post-install works
Diffstat (limited to 'core')
-rw-r--r--core/busybox/APKBUILD8
-rw-r--r--core/busybox/busybox.post-install2
l---------[-rw-r--r--]core/busybox/busybox.post-upgrade4
3 files changed, 7 insertions, 7 deletions
diff --git a/core/busybox/APKBUILD b/core/busybox/APKBUILD
index 123cf954..62e1fb76 100644
--- a/core/busybox/APKBUILD
+++ b/core/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.13.3
-pkgrel=2
+pkgrel=3
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license=GPL-2
@@ -34,6 +34,8 @@ build() {
make || return 1
make install DESTDIR="$pkgdir"
mkdir -p "$pkgdir"/usr/sbin "$pkgdir"/usr/bin
+ # we need /bin/sh to be able to execute post-install
+ ln -s /bin/busybox "$pkgdir"/bin/sh
}
md5sums="0cde6d2790e790837d6d7e82faae3ca1 busybox-1.13.3.tar.bz2
@@ -43,6 +45,6 @@ a743ec04f378b8456a725c7270b0be8b busybox-1.13.2-modprobe-errormsg.patch
3c43008545e069749d2d653532e1feb3 busybox-1.13.2-depmod2.patch
ed7537bc7193ab35f4e4ac6ce26d8270 busybox-1.13.3-ash.patch
4a5fe634708150f65b6d9b51dba20a51 busybox-1.13.3-hush.patch
-542ea5a470af0db6794ba38db9f8e779 busybox.post-install
-542ea5a470af0db6794ba38db9f8e779 busybox.post-upgrade
+56b78c358797cd15fb64719a48939267 busybox.post-install
+56b78c358797cd15fb64719a48939267 busybox.post-upgrade
fa6b9e2021102a53c43875ef0704d6f3 busyboxconfig"
diff --git a/core/busybox/busybox.post-install b/core/busybox/busybox.post-install
index 9bb6bf4c..8baed730 100644
--- a/core/busybox/busybox.post-install
+++ b/core/busybox/busybox.post-install
@@ -1,3 +1,3 @@
-#!/bin/busybox sh
+#!/bin/sh
/bin/busybox --install -s
diff --git a/core/busybox/busybox.post-upgrade b/core/busybox/busybox.post-upgrade
index 9bb6bf4c..1f4b450e 100644..120000
--- a/core/busybox/busybox.post-upgrade
+++ b/core/busybox/busybox.post-upgrade
@@ -1,3 +1 @@
-#!/bin/busybox sh
-
-/bin/busybox --install -s
+busybox.post-install \ No newline at end of file