summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-25 13:21:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-25 13:21:45 +0000
commit7ac86c6f324e387f9691cede4999bf6be00d9895 (patch)
tree8179c3961ea272c345ef5fe73e6586d82ed2f05e /core
parent0548ee69365251d412e87aeec733be28cde3f2da (diff)
downloadaports-7ac86c6f324e387f9691cede4999bf6be00d9895.tar.bz2
aports-7ac86c6f324e387f9691cede4999bf6be00d9895.tar.xz
core/alpine-conf: workaround for lbu to find libalpine.sh
Diffstat (limited to 'core')
-rw-r--r--core/alpine-conf/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/core/alpine-conf/APKBUILD b/core/alpine-conf/APKBUILD
index 34725cab..0f836eb7 100644
--- a/core/alpine-conf/APKBUILD
+++ b/core/alpine-conf/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
pkgver=2.0_alpha4
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
source=http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
@@ -10,6 +10,10 @@ license="GPL-2"
build() {
cd "$srcdir/$pkgname-$pkgver"
make PREFIX= || return 1
+
+ # workaround. fixed in git so this needs to be removed next release
+ sed -i -e 's:/usr/share/lbu/libalpine.sh:/lib/libalpine.sh:' lbu
+
make install PREFIX= DESTDIR="$pkgdir"
for i in commit exclude include status update; do
ln -s lbu "$pkgdir"/sbin/lbu_$i