summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-27 10:01:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-27 10:01:52 +0000
commit8b60075ab36ca1c9f0b48efd44e21899504fdac1 (patch)
tree42224edb68142b4e41ff58884869cbaa1779f95f /core
parent2c349455d9ee5940f386ab42ef552c7a7f8311b8 (diff)
downloadaports-8b60075ab36ca1c9f0b48efd44e21899504fdac1.tar.bz2
aports-8b60075ab36ca1c9f0b48efd44e21899504fdac1.tar.xz
core/busybox: create /tmp dir
the --initdb will be ignored if there are a /var/lib/apk/world file and will not create the needed /tmp. Since the apkovl contains this file, the /tmp will never be created, which causes busybox.post-install to fail due to the missing /tmp. The /tmp is provided by alpine-baselayout which depends on busybox so its not there whel busybox is installed. As a workaround we add /tmp to busybox package. The correct way to handle this is to make apk add create /tmp if its not there already when extracting the install script.
Diffstat (limited to 'core')
-rw-r--r--core/busybox/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/core/busybox/APKBUILD b/core/busybox/APKBUILD
index 62e1fb76..c8383b1a 100644
--- a/core/busybox/APKBUILD
+++ b/core/busybox/APKBUILD
@@ -33,7 +33,8 @@ build() {
make silentoldconfig || return 1
make || return 1
make install DESTDIR="$pkgdir"
- mkdir -p "$pkgdir"/usr/sbin "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/sbin "$pkgdir"/usr/bin "$pkgdir"/tmp
+ chmod 1777 "$pkgdir"/tmp
# we need /bin/sh to be able to execute post-install
ln -s /bin/busybox "$pkgdir"/bin/sh
}