summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-24 14:56:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-25 07:42:17 +0000
commit281d4aed8b0e73da41105e3f9c5f2589907528e6 (patch)
tree4bef6548d800faa831f2348a50b8f4b04169cf0f /core
parent9f6783f55ee5d69b94df0e6eb45ec37b95783ae9 (diff)
downloadaports-281d4aed8b0e73da41105e3f9c5f2589907528e6.tar.bz2
aports-281d4aed8b0e73da41105e3f9c5f2589907528e6.tar.xz
core/uclibc: another threading fix
Diffstat (limited to 'core')
-rw-r--r--core/uclibc/APKBUILD6
-rw-r--r--core/uclibc/uclibc-i386-floating-stacks.diff23
2 files changed, 28 insertions, 1 deletions
diff --git a/core/uclibc/APKBUILD b/core/uclibc/APKBUILD
index 2b71c25f..654ab8c7 100644
--- a/core/uclibc/APKBUILD
+++ b/core/uclibc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uclibc
pkgver=0.9.30.1
-pkgrel=9
+pkgrel=10
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -17,6 +17,7 @@ source="http://uclibc.org/downloads/$_mynamever.tar.bz2
0001-linuxthreads-fixes-from-Will-Newton-will.newton-AT-g.patch
pthread-new-aliasing-fix.diff
uclibc-resolv-cname-fix.diff
+ uclibc-i386-floating-stacks.diff
ppoll.patch
uclibcconfig
"
@@ -35,6 +36,8 @@ _compile() {
cd "$srcdir/$_mynamever/"
cp ../uclibcconfig .config
make silentoldconfig
+ # this is a hack to get uclibc-i386-floating-stacks.diff working
+ touch libc/sysdeps/linux/i386/sysdep.h
make || return 1
}
@@ -55,5 +58,6 @@ cf80c0d44a41e02f389be427ee615d61 uclibc-0.9.30.1-pthread_getattr_np.patch
bcd1c4c9c87f092fb4631559e6ec13ba 0001-linuxthreads-fixes-from-Will-Newton-will.newton-AT-g.patch
969187e1da84d0a0a5957b392a3d5a2b pthread-new-aliasing-fix.diff
bbb8475963e791f596c34c81ef5583d7 uclibc-resolv-cname-fix.diff
+0b3966ab7774ac42ecf34a7b596c661b uclibc-i386-floating-stacks.diff
60738298e377295d359768a09adac0bb ppoll.patch
0a87f57d3e5001027f43b7c959d96319 uclibcconfig"
diff --git a/core/uclibc/uclibc-i386-floating-stacks.diff b/core/uclibc/uclibc-i386-floating-stacks.diff
new file mode 100644
index 00000000..553195e6
--- /dev/null
+++ b/core/uclibc/uclibc-i386-floating-stacks.diff
@@ -0,0 +1,23 @@
+--- uClibc-0.9.30.1/libpthread/linuxthreads/sysdeps/i386/pt-machine.h Thu Sep 25 13:55:14 2008
++++ /root/uClibc-0.9.30.1-patched/libpthread/linuxthreads/sysdeps/i386/pt-machine.h Wed Jun 24 13:13:31 2009
+@@ -113,6 +113,8 @@
+ }
+ #endif /* __ASSEMBLER__ */
+
++#include "./useldt.h"
++
+ #endif /* pt-machine.h */
+
+ #endif
+--- uClibc-0.9.30.1/libpthread/linuxthreads/sysdeps/i386/useldt.h Tue May 15 00:35:00 2007
++++ /root/uClibc-0.9.30.1-patched/libpthread/linuxthreads/sysdeps/i386/useldt.h Wed Jun 24 13:22:38 2009
+@@ -23,7 +23,8 @@
+ #include <stddef.h> /* For offsetof. */
+ #include <stdlib.h> /* For abort(). */
+ #include <sysdep.h>
+-
++#include <sys/syscall.h>
++#include <kernel-features.h>
+
+ /* We don't want to include the kernel header. So duplicate the
+ information. */