summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-29 14:14:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-29 14:14:59 +0000
commit2c9e690985782c80e14e80dad8bcc8a53e8df51e (patch)
tree8e48bfd1dd40a1bedad8106790ce738390e8451b /core
parent8c41dd3caa1c4a60d0bdd6949fa38d38e550a3d5 (diff)
downloadaports-2c9e690985782c80e14e80dad8bcc8a53e8df51e.tar.bz2
aports-2c9e690985782c80e14e80dad8bcc8a53e8df51e.tar.xz
core/iscsitarget: split the kernel modules to separate APKBUILD
This now only contains the userland tools
Diffstat (limited to 'core')
-rw-r--r--core/iscsitarget/APKBUILD42
-rw-r--r--core/iscsitarget/iscsitarget-0.4.17+linux-2.6.28.patch78
2 files changed, 8 insertions, 112 deletions
diff --git a/core/iscsitarget/APKBUILD b/core/iscsitarget/APKBUILD
index d6dc2740..3bdf98ee 100644
--- a/core/iscsitarget/APKBUILD
+++ b/core/iscsitarget/APKBUILD
@@ -1,56 +1,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
pkgname=iscsitarget
pkgver=0.4.17
-pkgrel=1
-pkgdesc="Open Source iSCSI target with professional features"
+pkgrel=2
+pkgdesc="Open Source iSCSI target with professional features - userspace utils"
url="http://iscsitarget.sourceforge.net/"
license="GPL-2"
-depends="uclibc openssl"
+depends=
makedepends="openssl-dev"
-subpackages="$pkgname-doc $pkgname-grsec:mod"
-_kernels="grsec"
+subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
$pkgname-0.4.15-isns-set-scn-flag.patch
$pkgname-0.4.17-build.patch
- $pkgname-0.4.17+linux-2.6.28.patch
ietd.initd
ietd.confd
"
-for _i in $_kernels; do
- makedepends="$makedepends linux-${_i}-sources linux-${_i}-dev"
-done
-
build() {
cd "$srcdir"/$pkgname-$pkgver
for i in ../*.patch; do
msg "Applying $i"
patch -p1 < $i || return 1
done
-
- unset ARCH
- local k
- for k in $_kernels; do
- msg "Building kernel modules for $k"
- local kout="$srcdir"/$k
- mkdir -p "$kout"
- local ver=$(awk -F': ' '$1 ~ /Linux kernel version/ {print $2}' /boot/config-$k)
-
- cd "$kout"
- cp /boot/config-$k .config
- cp /boot/Module.symvers-$k Module.symvers
- make -C /usr/src/linux-$ver-$k O=$PWD silentoldconfig \
- || return 1
- make modules_prepare
-
- cd "$srcdir"/$pkgname-$pkgver
- make KSRC="$kout" kernel || return 1
- make KSRC="$kout" DISTDIR="$pkgdir" install-kernel || return 1
- done
- msg "Building userspace"
- make KSRC="$kout" usr || return 1
- make KSRC="$kout" DISTDIR="$pkgdir" install-usr install-doc
+ make usr || return 1
+ make DISTDIR="$pkgdir" install-usr install-doc
for i in etc/ietd.conf etc/initiators.*; do
install -Dm640 $i "$pkgdir"/$i || return 1
@@ -58,9 +32,9 @@ build() {
install -Dm755 ../ietd.initd "$pkgdir"/etc/init.d/ietd
install -Dm755 ../ietd.confd "$pkgdir"/etc/conf.d/ietd
}
+
md5sums="e79b437695fc50e7d054631855a16b1b iscsitarget-0.4.17.tar.gz
22512c5cf4cb62127730ce53d74ff28f iscsitarget-0.4.15-isns-set-scn-flag.patch
c9a9b839b3afcdecd1601511ee48a171 iscsitarget-0.4.17-build.patch
-f58dde50f72b04b7737b33e517e56208 iscsitarget-0.4.17+linux-2.6.28.patch
641513492f58a6cb13247d0028a50906 ietd.initd
06ba479d3533d557b8582abe6f182410 ietd.confd"
diff --git a/core/iscsitarget/iscsitarget-0.4.17+linux-2.6.28.patch b/core/iscsitarget/iscsitarget-0.4.17+linux-2.6.28.patch
deleted file mode 100644
index ec35cd52..00000000
--- a/core/iscsitarget/iscsitarget-0.4.17+linux-2.6.28.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From c5e70fc826aad5efb786c47d294e3c0c76246d63 Mon Sep 17 00:00:00 2001
-From: =?utf-8?q?Diego=20E.=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
-Date: Sat, 3 Jan 2009 00:09:43 +0100
-Subject: [PATCH] Fix building with Linux kernel 2.6.28 and later.
-
-With changeset 30c40d2c01f68c7eb1a41ab3552bdaf5dbf300d4 of the Linux
-kernel, the functions open_bdev_excl and close_bdev_excl were replaced with
-functionally-equivalent open_bdev_exclusive and close_bdev_exclusive.
-
-The new interface uses fmode_t instead of integer flags to carry on the
-opening mode for a block device, thus require some minor changes in the
-calls.
----
- kernel/block-io.c | 21 +++++++++++++++++++++
- 1 files changed, 21 insertions(+), 0 deletions(-)
-
-diff --git a/kernel/block-io.c b/kernel/block-io.c
-index e4a25f7..2c5f6f6 100644
---- a/kernel/block-io.c
-+++ b/kernel/block-io.c
-@@ -18,6 +18,14 @@
- #include "iscsi_dbg.h"
- #include "iotype.h"
-
-+#include <linux/version.h>
-+
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 28)
-+# define HAVE_OPEN_BDEV_EXCLUSIVE 1
-+#else
-+# define HAVE_OPEN_BDEV_EXCLUSIVE 0
-+#endif
-+
- struct blockio_data {
- char *path;
- struct block_device *bdev;
-@@ -154,14 +160,22 @@ blockio_open_path(struct iet_volume *volume, const char *path)
- {
- struct blockio_data *bio_data = volume->private;
- struct block_device *bdev;
-+#if HAVE_OPEN_BDEV_EXCLUSIVE
-+ fmode_t mode = FMODE_READ | ( LUReadonly(volume) ? 0 : FMODE_WRITE );
-+#else
- int flags = LUReadonly(volume) ? MS_RDONLY : 0;
-+#endif
- int err = 0;
-
- bio_data->path = kstrdup(path, GFP_KERNEL);
- if (!bio_data->path)
- return -ENOMEM;
-
-+#if HAVE_OPEN_BDEV_EXCLUSIVE
-+ bdev = open_bdev_exclusive(path, mode, THIS_MODULE);
-+#else
- bdev = open_bdev_excl(path, flags, THIS_MODULE);
-+#endif
- if (IS_ERR(bdev)) {
- err = PTR_ERR(bdev);
- eprintk("Can't open device %s, error %d\n", path, err);
-@@ -323,9 +337,16 @@ static void
- blockio_detach(struct iet_volume *volume)
- {
- struct blockio_data *bio_data = volume->private;
-+#if HAVE_OPEN_BDEV_EXCLUSIVE
-+ fmode_t mode = FMODE_READ | ( LUReadonly(volume) ? 0 : FMODE_WRITE );
-+#endif
-
- if (bio_data->bdev)
-+#if HAVE_OPEN_BDEV_EXCLUSIVE
-+ close_bdev_exclusive(bio_data->bdev, mode);
-+#else
- close_bdev_excl(bio_data->bdev);
-+#endif
- kfree(bio_data->path);
-
- kfree(volume->private);
---
-1.6.0.6
-