summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-16 14:51:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-16 14:58:04 +0000
commitcf26a40dcff09436df84223e6a7260a431b9e58f (patch)
tree56f201c1aee3c5de3052058cb30f9706fa0a32a3 /core
parent803c53c8d042b8336057858461b271421eff3b14 (diff)
downloadaports-cf26a40dcff09436df84223e6a7260a431b9e58f.tar.bz2
aports-cf26a40dcff09436df84223e6a7260a431b9e58f.tar.xz
core/iproute2: upgrade to 2.6.29.1. move to /sbin
Diffstat (limited to 'core')
-rw-r--r--core/iproute2/APKBUILD20
-rw-r--r--core/iproute2/iproute2.post-deinstall4
-rw-r--r--core/iproute2/iproute2.post-install6
3 files changed, 21 insertions, 9 deletions
diff --git a/core/iproute2/APKBUILD b/core/iproute2/APKBUILD
index 12cc3732..522e0c42 100644
--- a/core/iproute2/APKBUILD
+++ b/core/iproute2/APKBUILD
@@ -1,27 +1,29 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iproute2
-pkgver=2.6.28
+pkgver=2.6.29.1
+_realver=2.6.29-1
pkgrel=0
pkgdesc="IP Routing Utilities"
url="http://www.linux-foundation.org/en/Net:Iproute2"
license="GPL2"
-depends="uclibc"
+depends=
+install="$pkgname.post-install $pkgname.post-deinstall"
makedepends="bison flex"
subpackages="$pkgname-doc"
-source="http://devresources.linux-foundation.org/dev/$pkgname/download/$pkgname-$pkgver.tar.bz2"
+source="http://devresources.linux-foundation.org/dev/iproute2/download/$pkgname-$_realver.tar.bz2
+ $install"
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$srcdir"/$pkgname-$_realver
sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
sed -i 's:/usr/local:/usr:' tc/m_ipt.c include/iptables.h || return 1
sed -i 's:=/share:=/usr/share:' Makefile || return 1
- sed -i 's:=/sbin:=/usr/sbin:' Makefile || return 1
- sed -i 's:/lib/tc:/usr/lib/tc:' netem/Makefile || return 1
-
./configure || return 1
- make CCOPTS="-D_GNU_SOURCE $CFLAGS" LIBDIR=/usr/lib || return 1
+ make CCOPTS="-D_GNU_SOURCE $CFLAGS" LIBDIR=/lib || return 1
make DESTDIR="$pkgdir" install
}
-md5sums="595f9b17320f69e8d30d2fa80f1bca14 iproute2-2.6.28.tar.bz2"
+md5sums="c1bc258a6c345905e79935ac7a3cc582 iproute2-2.6.29-1.tar.bz2
+da1571ff1c0241c5c7f333a48d908927 iproute2.post-install
+ed8271a16ef48a769c50c3b529411018 iproute2.post-deinstall"
diff --git a/core/iproute2/iproute2.post-deinstall b/core/iproute2/iproute2.post-deinstall
new file mode 100644
index 00000000..dd117e5d
--- /dev/null
+++ b/core/iproute2/iproute2.post-deinstall
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+busybox --install -s
+
diff --git a/core/iproute2/iproute2.post-install b/core/iproute2/iproute2.post-install
new file mode 100644
index 00000000..36d567ea
--- /dev/null
+++ b/core/iproute2/iproute2.post-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+if [ "$(readlink /bin/ip)" = "/bin/busybox" ]; then
+ rm -f /bin/ip
+fi
+exit 0