summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-29 18:45:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-29 18:45:08 +0000
commiteca8f1df782e3429c49df35b7262db8c9429b5f2 (patch)
tree6a4f69f68886ae7928c5716432b24e42b0863863 /core
parentf62906d4e5b057ea3ac06b622025a0dddc43b1eb (diff)
downloadaports-eca8f1df782e3429c49df35b7262db8c9429b5f2.tar.bz2
aports-eca8f1df782e3429c49df35b7262db8c9429b5f2.tar.xz
core/linux-grsec: fix for localversion handling
Diffstat (limited to 'core')
-rw-r--r--core/linux-grsec/APKBUILD7
-rw-r--r--core/linux-grsec/kernelconfig4
2 files changed, 5 insertions, 6 deletions
diff --git a/core/linux-grsec/APKBUILD b/core/linux-grsec/APKBUILD
index abc52eca..6f02ab64 100644
--- a/core/linux-grsec/APKBUILD
+++ b/core/linux-grsec/APKBUILD
@@ -20,7 +20,6 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
subpackages="$pkgname-dev"
license="GPL-2"
-_ksrcdir=/usr/src/linux-${pkgver}-${_flavor}
_abi_release=${pkgver}-${_flavor}
_prepare() {
@@ -36,7 +35,7 @@ _prepare() {
mkdir -p "$srcdir"/build
cp "$srcdir"/$_config "$srcdir"/build/.config
- make -C "$_ksrcdir" O="$srcdir"/build HOSTCC="$CC" \
+ make -C "$srcdir"/linux-$_kernver O="$srcdir"/build HOSTCC="$CC" \
silentoldconfig
}
@@ -69,7 +68,7 @@ dev() {
local dir="$subpkgdir"/usr/src/linux-headers-${_abi_release}
mkdir -p "$dir"
cp "$srcdir"/kernelconfig "$dir"/.config
- make -j1 -C /usr/src/linux-$pkgver-grsec O="$dir" HOSTCC="$CC" \
+ make -j1 -C "$srcdir"/linux-$_kernver O="$dir" HOSTCC="$CC" \
silentoldconfig prepare scripts
install -Dm644 "$srcdir"/build/Module.symvers \
@@ -82,4 +81,4 @@ e2e49a250303720b31c4371905c105e3 grsecurity-2.1.14-2.6.29.5-200906152045.patch
7673b4521283ad41434a18ca18b16ad8 0001-linux-2.6.28.5-ipgre-strict-binding.patch
8f405c738b150c532c46eaad5390cca2 0002-linux-2.6.28.5-ipgre-optimize-hash-lookup.patch
ca05fd252783b82e01610e775cf56498 net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
-d5df3f51ca178a17492beca1419e427e kernelconfig"
+c9443dcc46eb70267b4cfe6a6694f637 kernelconfig"
diff --git a/core/linux-grsec/kernelconfig b/core/linux-grsec/kernelconfig
index 1479b349..425e5ced 100644
--- a/core/linux-grsec/kernelconfig
+++ b/core/linux-grsec/kernelconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.29.5
-# Tue Jun 23 12:22:32 2009
+# Mon Jun 29 16:25:46 2009
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -60,7 +60,7 @@ CONFIG_EXPERIMENTAL=y
CONFIG_LOCK_KERNEL=y
CONFIG_INIT_ENV_ARG_LIMIT=32
CONFIG_LOCALVERSION=""
-CONFIG_LOCALVERSION_AUTO=y
+# CONFIG_LOCALVERSION_AUTO is not set
CONFIG_SWAP=y
CONFIG_SYSVIPC=y
CONFIG_SYSVIPC_SYSCTL=y