summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-11 13:35:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-11 13:35:27 +0000
commit3744f0b3b510f2cf038b01d926cee645dabbd285 (patch)
tree5fbb8e88c24a989abb391ffffe02bb271b93cbed /core
parentb0a83e81230c8a6e83c139307079b33c1cd9441f (diff)
downloadaports-3744f0b3b510f2cf038b01d926cee645dabbd285.tar.bz2
aports-3744f0b3b510f2cf038b01d926cee645dabbd285.tar.xz
core/alpine-baselayout: upgrade to 2.0_beta1
Diffstat (limited to 'core')
-rw-r--r--core/alpine-baselayout/APKBUILD14
-rw-r--r--core/alpine-baselayout/mdev-initd.patch13
-rw-r--r--core/alpine-baselayout/mdev-usbdisk.patch36
3 files changed, 4 insertions, 59 deletions
diff --git a/core/alpine-baselayout/APKBUILD b/core/alpine-baselayout/APKBUILD
index 6f449f19..a993d687 100644
--- a/core/alpine-baselayout/APKBUILD
+++ b/core/alpine-baselayout/APKBUILD
@@ -1,22 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-baselayout
-pkgver=2.0_alpha12
-pkgrel=2
+pkgver=2.0_beta1
+pkgrel=0
pkgdesc="Alpine base dir structure and init scripts"
url=http://git.alpinelinux.org/cgit/alpine-baselayout
depends=
-source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
- mdev-usbdisk.patch
- mdev-initd.patch"
+source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
license=GPL-2
build() {
cd "$srcdir"/$pkgname-$pkgver
- patch -p1 < ../mdev-usbdisk.patch
- patch -p1 < ../mdev-initd.patch
make
make install PREFIX= DESTDIR="$pkgdir" || return 1
}
-md5sums="5549065f87374ea5c4249cba6ba85d16 alpine-baselayout-2.0_alpha12.tar.bz2
-4bf6829d019d2b43dd45208c7390c91c mdev-usbdisk.patch
-6d3c5789e6f02c209a6f7fbf047ea3df mdev-initd.patch"
+md5sums="6b25fc0c261e9182a68582c38249a3e8 alpine-baselayout-2.0_beta1.tar.bz2"
diff --git a/core/alpine-baselayout/mdev-initd.patch b/core/alpine-baselayout/mdev-initd.patch
deleted file mode 100644
index 2af84976..00000000
--- a/core/alpine-baselayout/mdev-initd.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/init.d/mdev b/init.d/mdev
-index fb9e8d5..42f6a1c 100755
---- a/init.d/mdev
-+++ b/init.d/mdev
-@@ -2,7 +2,7 @@
-
- depend() {
- provide dev
-- need sysfs mdev-mount
-+ need sysfs
- before checkfs fsck
- keyword novserver
- }
diff --git a/core/alpine-baselayout/mdev-usbdisk.patch b/core/alpine-baselayout/mdev-usbdisk.patch
deleted file mode 100644
index cfa0331f..00000000
--- a/core/alpine-baselayout/mdev-usbdisk.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-commit 9542c009af40331e8770256148aa13075f4d8294
-Author: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu Jun 4 14:11:43 2009 +0000
-
- mdev: look for FAT in device to create usbdisk link
-
- it seems like mkfs.vfat creates MBR signature
-
-diff --git a/mdev.conf b/mdev.conf
-index 3e2339b..6ee65a2 100644
---- a/mdev.conf
-+++ b/mdev.conf
-@@ -27,7 +27,7 @@ ptmx root:tty 0666
- # ram.*
- ram([0-9]*) root:disk 0660 >rd/%1
- loop([0-9]+) root:disk 0660 >loop/
--sd[a-z]1 root:disk 0660 */lib/mdev/usbdisk_link
-+sd[a-z].* root:disk 0660 */lib/mdev/usbdisk_link
- hd[a-z][0-9]* root:disk 0660 */lib/mdev/ide_links
- md[0-9] root:disk 0660
-
-diff --git a/usbdisk_link b/usbdisk_link
-index 6acaad3..750242b 100644
---- a/usbdisk_link
-+++ b/usbdisk_link
-@@ -14,8 +14,8 @@ if [ -e /sys/block/$MDEV ]; then
- # if /sys device path contains '/usb[0-9]' then we assume its usb
- # also, if its an usb without partitions we require FAT
- if [ "${SYSDEV##*/usb[0-9]}" != "$SYSDEV" ]; then
-- # do not create link if there is an MBR signature
-- dd if=/dev/$MDEV bs=1 count=2 skip=510 2>/dev/null | hexdump | grep aa55 >/dev/null && exit 0
-+ # do not create link if there is not FAT
-+ dd if=/dev/$MDEV bs=512 count=1 2>/dev/null | strings | grep FAT >/dev/null || exit 0
-
- ln -sf $MDEV usbdisk
- # keep this for compat. people have it in fstab