summaryrefslogtreecommitdiffstats
path: root/extra/alsa-lib
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2009-04-14 12:31:40 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2009-04-14 12:31:40 +0000
commitd1d77566acd00b507e94315db03962d40d5e61ba (patch)
tree143220614c31d23846d5997e013a54dcfb610bae /extra/alsa-lib
parentec9f198db36b85dbd15d437912f54351fb6dac4e (diff)
parentdc25b81229d7f15420c73579221a02af5357b8fb (diff)
downloadaports-d1d77566acd00b507e94315db03962d40d5e61ba.tar.bz2
aports-d1d77566acd00b507e94315db03962d40d5e61ba.tar.xz
Merge commit 'ncopa/master'
Conflicts: core/e2fsprogs/APKBUILD extra/nfs-utils/APKBUILD
Diffstat (limited to 'extra/alsa-lib')
-rw-r--r--extra/alsa-lib/APKBUILD9
-rw-r--r--extra/alsa-lib/nocxx.patch15
2 files changed, 21 insertions, 3 deletions
diff --git a/extra/alsa-lib/APKBUILD b/extra/alsa-lib/APKBUILD
index d253ca85..7bb0b7be 100644
--- a/extra/alsa-lib/APKBUILD
+++ b/extra/alsa-lib/APKBUILD
@@ -1,19 +1,22 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alsa-lib
-pkgver=1.0.18
+pkgver=1.0.19
pkgrel=0
pkgdesc="An alternative implementation of Linux sound support"
url="http://www.alsa-project.org"
license="GPL"
depends="uclibc"
subpackages="$pkgname-dev"
-source="ftp://ftp.alsa-project.org/pub/lib/$pkgname-$pkgver.tar.bz2"
+source="ftp://ftp.alsa-project.org/pub/lib/$pkgname-$pkgver.tar.bz2
+ nocxx.patch"
build ()
{
cd "$srcdir/$pkgname-$pkgver"
+ patch configure < ../nocxx.patch || return 1
./configure --prefix=/usr --disable-python
make || return 1
make -j1 DESTDIR="$pkgdir" install
}
-md5sums="de60df7541fafe8c6a3397e0f105ff0e alsa-lib-1.0.18.tar.bz2"
+md5sums="73db3666c211e5fb023bb77450cf430d alsa-lib-1.0.19.tar.bz2
+28513788ba4d556ccd538867dc6205ab nocxx.patch"
diff --git a/extra/alsa-lib/nocxx.patch b/extra/alsa-lib/nocxx.patch
new file mode 100644
index 00000000..beb1ab90
--- /dev/null
+++ b/extra/alsa-lib/nocxx.patch
@@ -0,0 +1,15 @@
+--- a/configure 2004-12-07 21:34:23.205172545 +0000
++++ b/configure 2004-12-07 21:37:17.726654782 +0000
+@@ -5148,10 +5148,8 @@
+ :
+ else
+ { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&5;}
++ { echo "C++ sucks, ignoring ..." >&5; }; }
+ fi
+
+ ac_ext=cc