summaryrefslogtreecommitdiffstats
path: root/extra/asterisk/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-09 08:15:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-09 08:15:39 +0000
commit56ec02d524f6b9cc237b86ebb5dbbf84232d2af7 (patch)
treee35683d27afd1527fc786199989a82ae6532aa42 /extra/asterisk/APKBUILD
parent31109f210df44c1822c8f9d576d0e08d6fa90232 (diff)
downloadaports-56ec02d524f6b9cc237b86ebb5dbbf84232d2af7.tar.bz2
aports-56ec02d524f6b9cc237b86ebb5dbbf84232d2af7.tar.xz
extra/asterisk: added depend() to init.d script
This is needed to make sure asterisk is started after network. Funny things like missing .ctl files might happen otherwise. This hsould fix #38
Diffstat (limited to 'extra/asterisk/APKBUILD')
-rw-r--r--extra/asterisk/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/extra/asterisk/APKBUILD b/extra/asterisk/APKBUILD
index 2e0f680c..bdc8dd5f 100644
--- a/extra/asterisk/APKBUILD
+++ b/extra/asterisk/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=asterisk
pkgver=1.6.0.9
-pkgrel=2
+pkgrel=3
pkgdesc="Asterisk: A Module Open Source PBX System"
url="http://www.asterisk.org/"
license="GPL"
-depends="ncurses popt zlib newt dahdi-linux dahdi-tools libltdl libpri freetds"
+depends="dahdi-linux"
makedepends="autoconf automake libtool ncurses-dev popt-dev newt-dev zlib-dev
- postgresql-dev unixodbc-dev dahdi-tools-dev libpri-dev g++ tar
+ postgresql-dev unixodbc-dev dahdi-tools-dev libpri-dev tar
freetds-dev"
install="$pkgname.pre-install $pkgname.post-install"
subpackages="$pkgname-dev $pkgname-doc $pkgname-pgsql $pkgname-odbc
@@ -67,19 +67,19 @@ _find_and_move() {
}
pgsql() {
- depends="uclibc asterisk libpq zlib"
+ depends=
install=
_find_and_move '*_pgsql*'
}
odbc() {
- depends="uclibc asterisk unixodbc"
+ depends=
install=
_find_and_move '*odbc*'
}
tds() {
- depends="uclibc asterisk freetds"
+ depends=
install=
_find_and_move '*_tds*'
}
@@ -91,5 +91,5 @@ b00c9d98ce2ad445501248a197c6e436 100-uclibc-daemon.patch
5008f51c737ec91f5047519bc9f25b85 103-rundir.patch
b4a97cb1ec3cc3f71a10ce8c067ab430 asterisk.pre-install
62ecffc90b6714b85f377d1fac73c58b asterisk.post-install
-9748fc0fb3cf43b18a68584bdc20cb6c asterisk.initd
+c618b7fdf4a9edf4cde6d8ccd1e32ee6 asterisk.initd
ed31d7ba37bcf8b0346dcf8593c395f0 asterisk.confd"