summaryrefslogtreecommitdiffstats
path: root/extra/dnsmasq
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
commitb70981b68efcce5256eb11c6cd26ae123b10b6ea (patch)
treea38be6efae5e2ba15c2e839504632f9b7bfd5f91 /extra/dnsmasq
parent2b4df81538b8398442d5296650905c70341dd8d3 (diff)
downloadaports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.bz2
aports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.xz
moved extra/* to main/
and fixed misc build issues
Diffstat (limited to 'extra/dnsmasq')
-rw-r--r--extra/dnsmasq/APKBUILD37
-rw-r--r--extra/dnsmasq/dnsmasq.confd4
-rw-r--r--extra/dnsmasq/dnsmasq.initd38
3 files changed, 0 insertions, 79 deletions
diff --git a/extra/dnsmasq/APKBUILD b/extra/dnsmasq/APKBUILD
deleted file mode 100644
index 328d54df..00000000
--- a/extra/dnsmasq/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=dnsmasq
-pkgver=2.49
-pkgrel=0
-pkgdesc="Small forwarding DNS server"
-url="http://www.thekelleys.org.uk/dnsmasq/"
-license="GPL-2"
-depends=
-subpackages="$pkgname-doc"
-source="http://www.thekelleys.org.uk/dnsmasq/$pkgname-$pkgver.tar.gz
- $pkgname.initd
- $pkgname.confd
- "
-
-build() {
- # src_unpack
- cd "$srcdir/$pkgname-$pkgver"
- sed -i -e 's/^AWK.*/AWK = awk/' Makefile
- make PREFIX=/usr \
- CFLAGS="$CFLAGS" \
- DBUS_LIBS= \
- DBUS_CFLAGS= \
- DBUS_MINOR= \
- all || return 1
- make PREFIX=/usr \
- DESTDIR="$pkgdir" \
- DBUS_LIBS= \
- DBUS_CFLAGS= \
- DBUS_MINOR= \
- install
- install -D -m755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -D -m644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
- install dnsmasq.conf.example "$pkgdir"/etc/dnsmasq.conf
-}
-md5sums="7ccc861d8a733474f9c0a0a127006ee9 dnsmasq-2.49.tar.gz
-fbea3f4a794a6a00cc6fe79c6d44606a dnsmasq.initd
-5990c2d2cb92209feacf8f3a5a7d0831 dnsmasq.confd"
diff --git a/extra/dnsmasq/dnsmasq.confd b/extra/dnsmasq/dnsmasq.confd
deleted file mode 100644
index 47826dd5..00000000
--- a/extra/dnsmasq/dnsmasq.confd
+++ /dev/null
@@ -1,4 +0,0 @@
-# /etc/conf.d/dnsmasq: config file for /etc/init.d/dnsmasq
-
-# See the dnsmasq(8) man page for possible options to put here.
-DNSMASQ_OPTS=""
diff --git a/extra/dnsmasq/dnsmasq.initd b/extra/dnsmasq/dnsmasq.initd
deleted file mode 100644
index 44109e98..00000000
--- a/extra/dnsmasq/dnsmasq.initd
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/files/dnsmasq-init,v 1.13 2008/01/29 15:06:30 flameeyes Exp $
-
-opts="reload"
-
-depend() {
- provide dns
- need localmount net
- after bootmisc
-}
-
-start() {
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --exec /usr/sbin/dnsmasq \
- --pidfile /var/run/dnsmasq.pid \
- -- -x /var/run/dnsmasq.pid ${DNSMASQ_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --exec /usr/sbin/dnsmasq \
- --pidfile /var/run/dnsmasq.pid
- eend $?
-}
-
-reload() {
- ebegin "Reloading ${SVCNAME}"
- if ! service_started "${SVCNAME}" ; then
- eend 1 "${SVCNAME} is not started"
- return 1
- fi
- start-stop-daemon --stop --oknodo --signal HUP \
- --exec /usr/sbin/dnsmasq --pidfile /var/run/dnsmasq.pid
- eend $?
-}