summaryrefslogtreecommitdiffstats
path: root/extra/email
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-01-01 12:37:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-01-01 12:37:45 +0000
commiteba4f64c1aa1fac8000e97313f22c90c4a135aec (patch)
tree76c1776b7a36a1ed56475cefaff935c5e63ed4d2 /extra/email
parent3c4a7b431a1d8e326cc76e2eca4b4f3f5efb46e4 (diff)
downloadaports-eba4f64c1aa1fac8000e97313f22c90c4a135aec.tar.bz2
aports-eba4f64c1aa1fac8000e97313f22c90c4a135aec.tar.xz
extra/email: correct location for doc
Diffstat (limited to 'extra/email')
-rw-r--r--extra/email/APKBUILD12
-rw-r--r--extra/email/email-3.1.0-doc.patch10
2 files changed, 19 insertions, 3 deletions
diff --git a/extra/email/APKBUILD b/extra/email/APKBUILD
index 4982a3c1..984cf090 100644
--- a/extra/email/APKBUILD
+++ b/extra/email/APKBUILD
@@ -7,17 +7,21 @@ url="http://www.cleancode.org/projects/email"
license="GPL"
depends="uclibc openssl"
makedepends="openssl-dev"
-source="http://www.cleancode.org/downloads/email/email-3.1.0.tar.bz2"
+source="http://www.cleancode.org/downloads/email/email-3.1.0.tar.bz2
+ email-3.1.0-ldflags.patch
+ email-3.1.0-doc.patch
+ "
subpackages="$pkgname-doc"
build() {
cd "$srcdir/$pkgname-$pkgver"
- for i in ../../*.patch; do
+ for i in ../*.patch; do
msg "Applying ${i##*/}"
patch -p1 -i $i || return 1
done
+ autoconf
./configure \
--prefix=/usr \
@@ -27,4 +31,6 @@ build() {
make DESTDIR="$pkgdir" install
}
-md5sums="dc347ea65b58f49ee4fe8f578ea13535 email-3.1.0.tar.bz2"
+md5sums="dc347ea65b58f49ee4fe8f578ea13535 email-3.1.0.tar.bz2
+32858c5d06146564ac6ac04375511838 email-3.1.0-ldflags.patch
+a1f7250f69af588a8e6ec65930cdd85a email-3.1.0-doc.patch"
diff --git a/extra/email/email-3.1.0-doc.patch b/extra/email/email-3.1.0-doc.patch
new file mode 100644
index 00000000..d7467844
--- /dev/null
+++ b/extra/email/email-3.1.0-doc.patch
@@ -0,0 +1,10 @@
+--- email-3.1.0.orig/configure.in Thu Jan 1 12:00:53 2009
++++ email-3.1.0/configure.in Thu Jan 1 12:01:16 2009
+@@ -65,7 +65,6 @@
+ CFLAGS="$CFLAGS -DUSE_GNU_STRFTIME"
+ fi
+
+-AC_SUBST(docdir, ["\${prefix}/doc/email-${version}"])
+ AC_SUBST(ver, ["$version"])
+
+ CFLAGS="$CFLAGS -I$cwd -I$cwd/src -I$cwd/include -I../include -I$cwd/dlib/include"