summaryrefslogtreecommitdiffstats
path: root/extra/libconfig
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-12-02 15:50:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-12-02 15:50:48 +0000
commitad16a723c335745f312b4d224a83b1d4bbe1170a (patch)
treecc525a8e53d456334e6627f1f114fd2c9dcd3129 /extra/libconfig
parent0b2b9167fc2de1f8a9d289b406c3e3de53c94ffb (diff)
downloadaports-ad16a723c335745f312b4d224a83b1d4bbe1170a.tar.bz2
aports-ad16a723c335745f312b4d224a83b1d4bbe1170a.tar.xz
extra/libconfig: new aport
Diffstat (limited to 'extra/libconfig')
-rw-r--r--extra/libconfig/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/extra/libconfig/APKBUILD b/extra/libconfig/APKBUILD
new file mode 100644
index 00000000..cf1d05a9
--- /dev/null
+++ b/extra/libconfig/APKBUILD
@@ -0,0 +1,22 @@
+pkgname=libconfig
+pkgver=1.3.1
+pkgrel=0
+pkgdesc="a simple library for manipulating structured configuration files"
+url="http://www.hyperrealm.com/libconfig/"
+license='LGPL'
+depends="uclibc"
+source="http://www.hyperrealm.com/$pkgname/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-doc $pkgname-dev"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --disable-cxx
+ make || return 1
+ make DESTDIR="$pkgdir/" install
+}
+
+md5sums="" #generate with 'abuild checksum'
+md5sums="f02bfa27a21b3040089026975b9dc0b8 libconfig-1.3.1.tar.gz"