summaryrefslogtreecommitdiffstats
path: root/extra/libtheora
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-28 10:08:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-28 10:08:28 +0000
commited1b3209b6c34161e0f7ca150d99655da23214c0 (patch)
tree3a0cdb7255ea3e7470c9cf80889bd1ab3e0d7c1a /extra/libtheora
parenta03c2d5e12fae35af10627f03848c652ad5d13f4 (diff)
downloadaports-ed1b3209b6c34161e0f7ca150d99655da23214c0.tar.bz2
aports-ed1b3209b6c34161e0f7ca150d99655da23214c0.tar.xz
extra/libtheora: new aport
An open video codec developed by the Xiph.org http://www.xiph.org
Diffstat (limited to 'extra/libtheora')
-rw-r--r--extra/libtheora/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/extra/libtheora/APKBUILD b/extra/libtheora/APKBUILD
new file mode 100644
index 00000000..584a5335
--- /dev/null
+++ b/extra/libtheora/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libtheora
+pkgver=1.0
+pkgrel=0
+pkgdesc="An open video codec developed by the Xiph.org"
+url="http://www.xiph.org"
+license="custom"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="libogg uclibc"
+makedepends="libvorbis-dev libogg-dev g++"
+source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/libtheora-$pkgver
+ ./configure --prefix=/usr \
+ --enable-shared \
+ --disable-static || return 1
+
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ install -m755 -d ""$pkgdir"/usr/share/licenses/$pkgname"
+ install -m644 LICENSE COPYING "$pkgdir"/usr/share/licenses/$pkgname/
+}
+md5sums="c963937053f45a7878954bed37ceb182 libtheora-1.0.tar.bz2"