summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-28 09:52:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-28 09:52:04 +0000
commit732f6369ce5bc0a50a8b07848c6a2f384bc316fe (patch)
tree5453422f9c396c246e93a3a33a90b5521718a71d /extra
parent3dced00678c95c0330228f4987d9f2b23b4856a7 (diff)
downloadaports-732f6369ce5bc0a50a8b07848c6a2f384bc316fe.tar.bz2
aports-732f6369ce5bc0a50a8b07848c6a2f384bc316fe.tar.xz
extra/iputils: new aport
IP Configuration Utilities (and Ping) http://www.linuxfoundation.org/en/Net:Iputils
Diffstat (limited to 'extra')
-rw-r--r--extra/iputils/APKBUILD25
-rw-r--r--extra/iputils/iputils-20070202-no-open-max.patch16
2 files changed, 41 insertions, 0 deletions
diff --git a/extra/iputils/APKBUILD b/extra/iputils/APKBUILD
new file mode 100644
index 00000000..6b4d3eed
--- /dev/null
+++ b/extra/iputils/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=iputils
+pkgver=20071127
+pkgrel=0
+pkgdesc="IP Configuration Utilities (and Ping)"
+url="http://www.linuxfoundation.org/en/Net:Iputils"
+license="GPL"
+depends="uclibc"
+source="http://www.skbuff.net/$pkgname/$pkgname-s$pkgver.tar.bz2
+ $pkgname-20070202-no-open-max.patch"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-s$pkgver
+ patch -Np1 -i ../iputils-20070202-no-open-max.patch || return 1
+ make KERNEL_INCLUDE=/usr/include || return 1
+ for i in arping clockdiff rarpd rdisc tftpd tracepath tracepath6; do
+ install -D -m755 $i "$pkgdir"/usr/sbin/$i
+ done
+ for i in ping ping6 traceroute6; do
+ install -D -m4755 $i "$pkgdir"/bin/$i
+ done
+}
+md5sums="12245e9927d60ff5cf4a99d265bcb7d3 iputils-s20071127.tar.bz2
+a2cbc0174dd883f68297aa7f3e7c4f5c iputils-20070202-no-open-max.patch"
diff --git a/extra/iputils/iputils-20070202-no-open-max.patch b/extra/iputils/iputils-20070202-no-open-max.patch
new file mode 100644
index 00000000..5013ba4f
--- /dev/null
+++ b/extra/iputils/iputils-20070202-no-open-max.patch
@@ -0,0 +1,16 @@
+the OPEN_MAX define has been removed in newer kernel headers so use the
+proper method of getting the value dynamically
+
+http://bugs.gentoo.org/195861
+
+--- a/rdisc.c
++++ b/rdisc.c
+@@ -247,7 +247,7 @@ void do_fork(void)
+ if ((pid=fork()) != 0)
+ exit(0);
+
+- for (t = 0; t < OPEN_MAX; t++)
++ for (t = 0; t < sysconf(_SC_OPEN_MAX); t++)
+ if (t != s)
+ close(t);
+