summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-21 08:54:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-21 08:54:30 +0000
commite0cb531abdbe53cc75e529f58398725f5658ce73 (patch)
treeb167910a7fe292e51f212e3547d35f4963ac45b2 /extra
parent69832c36aaf715044b978334d4a0ceda102a2754 (diff)
downloadaports-e0cb531abdbe53cc75e529f58398725f5658ce73.tar.bz2
aports-e0cb531abdbe53cc75e529f58398725f5658ce73.tar.xz
extra/hunspell: new aport
Spell checker and morphological analyzer library and program http://hunspell.sourceforge.net/
Diffstat (limited to 'extra')
-rw-r--r--extra/hunspell/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/extra/hunspell/APKBUILD b/extra/hunspell/APKBUILD
new file mode 100644
index 00000000..4d3fa732
--- /dev/null
+++ b/extra/hunspell/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=hunspell
+pkgver=1.2.8
+pkgrel=0
+pkgdesc="Spell checker and morphological analyzer library and program"
+url="http://hunspell.sourceforge.net/"
+license="GPL LGPL MPL"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="libgcc uclibc++"
+makedepends="uclibc++-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir/hunspell-$pkgver"
+ export CXX="${CXX_UC:-g++-uc}"
+
+ ./configure --prefix=/usr --disable-static || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="1177af54a09e320d2c24015f29c3a93e hunspell-1.2.8.tar.gz"