summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-06-15 11:48:35 +0000
committerMichael Mason <ms13sp@gmail.com>2009-06-15 11:48:35 +0000
commit4a299b356e5aeb85e8ad07ea2be6605c4059e5d1 (patch)
tree50f316cf292cf13a130d1cf2873f02809dc9c2d4 /extra
parente80c6238f4c1727c057c2fd7ca06ae05f20af234 (diff)
parent1db6e899072d31a2704533903cfe8f6fab1c98ec (diff)
downloadaports-4a299b356e5aeb85e8ad07ea2be6605c4059e5d1.tar.bz2
aports-4a299b356e5aeb85e8ad07ea2be6605c4059e5d1.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
Diffstat (limited to 'extra')
-rw-r--r--extra/glib/APKBUILD11
-rw-r--r--extra/libexif/APKBUILD20
-rw-r--r--extra/libpng/APKBUILD8
-rw-r--r--extra/perl-xml-simple/APKBUILD22
4 files changed, 53 insertions, 8 deletions
diff --git a/extra/glib/APKBUILD b/extra/glib/APKBUILD
index caa05e01..f67d7801 100644
--- a/extra/glib/APKBUILD
+++ b/extra/glib/APKBUILD
@@ -1,20 +1,22 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail.com>
pkgname=glib
-pkgver=2.20.0
+pkgver=2.20.3
pkgrel=0
pkgdesc="Common C routines used by Gtk+ and other libs"
url="http://www.gtk.org"
license='GPL'
-depends="gettext libiconv"
+depends=
makedepends="gettext-dev libiconv-dev pkgconfig"
source="http://ftp.gnome.org/pub/gnome/sources/glib/${pkgver%.*}/glib-$pkgver.tar.bz2"
subpackages="$pkgname-doc $pkgname-dev"
+depends_dev="perl gettext libiconv"
+
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr \
- --mandir=/usr/share/man
+ --mandir=/usr/share/man
make || return 1
make DESTDIR="$pkgdir/" install
}
@@ -22,8 +24,7 @@ build() {
# move the stuff in /usr/bin to the glib-dev package
dev() {
default_dev
- depends="$depends perl"
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-md5sums="05188e560dbd8bddd568e24ce10dd003 glib-2.20.0.tar.bz2"
+md5sums="1173688c58b4b62809c83bb07a2cf71a glib-2.20.3.tar.bz2"
diff --git a/extra/libexif/APKBUILD b/extra/libexif/APKBUILD
new file mode 100644
index 00000000..c9f244b0
--- /dev/null
+++ b/extra/libexif/APKBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libexif
+pkgver=0.6.17
+pkgrel=0
+pkgdesc="A library to parse an EXIF file and read the data from those tags"
+url="http://sourceforge.net/projects/libexif"
+license="LGPL"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends=
+source="http://downloads.sf.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="f7cf4e623a48c9a3b13f7f95f0a41015 libexif-0.6.17.tar.bz2"
diff --git a/extra/libpng/APKBUILD b/extra/libpng/APKBUILD
index b6783069..3d97159e 100644
--- a/extra/libpng/APKBUILD
+++ b/extra/libpng/APKBUILD
@@ -1,15 +1,17 @@
# Contributor: Carlo Landmeter <clandmeter at gmail>
# Maintainer: Carlo Landmeter <clandmeter at gmail>
pkgname=libpng
-pkgver=1.2.36
+pkgver=1.2.37
pkgrel=0
pkgdesc="Portable Network Graphics library"
url="http://www.libpng.org/"
license="GPL"
-depends="zlib"
+depends=
makedepends="zlib-dev"
subpackages="$pkgname-doc $pkgname-dev"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+depends_dev="zlib-dev"
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -22,4 +24,4 @@ build() {
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE || return 1
}
-md5sums="4779cd011409ea9b591e11638781f0bf libpng-1.2.36.tar.gz"
+md5sums="7480dbbf9f6c3297faf6fe52ec9b91ab libpng-1.2.37.tar.gz"
diff --git a/extra/perl-xml-simple/APKBUILD b/extra/perl-xml-simple/APKBUILD
new file mode 100644
index 00000000..74d2ecbe
--- /dev/null
+++ b/extra/perl-xml-simple/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-xml-simple
+pkgver=2.18
+pkgrel=0
+pkgdesc="Simple XML parser for perl"
+url="http://search.cpan.org/dist/XML-Simple/"
+license="PerlArtistic"
+subpackages="$pkgname-doc"
+depends="perl-xml-parser perl"
+makedepends="perl-dev"
+source="ftp://ftp.cpan.org/pub/CPAN/authors/id/G/GR/GRANTM/XML-Simple-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/XML-Simple-$pkgver
+ perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name 'perllocal.pod' -delete
+}
+md5sums="593aa8001e5c301cdcdb4bb3b63abc33 XML-Simple-2.18.tar.gz"