summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2009-06-12 07:45:45 +0000
committerLeonardo Arena <rnalrd@gmail.com>2009-06-12 07:45:45 +0000
commit81317f10c03457ace8fa498772795071f57f984b (patch)
treef867c5c590caba0aadc4c7e917fc07855c745ffe /extra
parente355833589ec8688a171fcf6ab2f83286aaf74a3 (diff)
downloadaports-81317f10c03457ace8fa498772795071f57f984b.tar.bz2
aports-81317f10c03457ace8fa498772795071f57f984b.tar.xz
extra/perl-uri-escape: moved to extra
Diffstat (limited to 'extra')
-rw-r--r--extra/perl-uri-escape/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/extra/perl-uri-escape/APKBUILD b/extra/perl-uri-escape/APKBUILD
new file mode 100644
index 00000000..4cd3b727
--- /dev/null
+++ b/extra/perl-uri-escape/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=perl-uri-escape
+_realname=URI
+pkgver=1.38
+pkgrel=0
+pkgdesc="Uniform Resource Identifiers (absolute and relative)"
+url="http://search.cpan.org/~gaas/URI-1.38/"
+license="GPL PerlArtistic"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ rm $pkgdir/usr/lib/perl5/5.10.0/i686-linux/perllocal.pod
+}
+
+md5sums="35fba2715eb8ac56e8e30244ae69ff65 URI-1.38.tar.gz"