summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-13 11:57:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-13 11:57:53 +0000
commit25fcf68e9fb9ccae1c8985da99f183a3369e3722 (patch)
tree0844b08d3e9d782e8556939f3f6cb051953bceda /extra
parent1f0eb2ae35eeed60e543571c97c4c6ebc2a84580 (diff)
downloadaports-25fcf68e9fb9ccae1c8985da99f183a3369e3722.tar.bz2
aports-25fcf68e9fb9ccae1c8985da99f183a3369e3722.tar.xz
extra/tdb: moved from core
Is not used by lbu commit anymore
Diffstat (limited to 'extra')
-rw-r--r--extra/tdb/APKBUILD24
-rw-r--r--extra/tdb/tdb-1.0.6-gcc3.patch41
-rw-r--r--extra/tdb/tdb-1.0.6-no-gdbm.patch16
3 files changed, 81 insertions, 0 deletions
diff --git a/extra/tdb/APKBUILD b/extra/tdb/APKBUILD
new file mode 100644
index 00000000..4e9c2b83
--- /dev/null
+++ b/extra/tdb/APKBUILD
@@ -0,0 +1,24 @@
+pkgdesc="A Trivial Database"
+pkgname=tdb
+pkgver=1.0.6
+pkgrel=1
+url="http://sourceforge.net/projects/tdb"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ $pkgname-1.0.6-gcc3.patch
+ $pkgname-1.0.6-no-gdbm.patch"
+license="GPL-2"
+
+subpackages="$pkgname-dev $pkgname-doc"
+depends="uclibc"
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ patch -p1 -i $srcdir/$pkgname-1.0.6-gcc3.patch || return 1
+ patch -p0 -i $srcdir/$pkgname-1.0.6-no-gdbm.patch || return 1
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make || return 1
+ make install DESTDIR=$pkgdir
+}
+md5sums="6b643fdeb48304010dcd5f675e458b58 tdb-1.0.6.tar.gz
+3dbbde1145303ad43730f2bc1bb3b82b tdb-1.0.6-gcc3.patch
+8a4247a9e3c5af757cfa1d5c20733642 tdb-1.0.6-no-gdbm.patch"
diff --git a/extra/tdb/tdb-1.0.6-gcc3.patch b/extra/tdb/tdb-1.0.6-gcc3.patch
new file mode 100644
index 00000000..a17afbac
--- /dev/null
+++ b/extra/tdb/tdb-1.0.6-gcc3.patch
@@ -0,0 +1,41 @@
+--- tdb-1.0.6/tdbtool.c.old 2001-12-10 22:45:47.000000000 -0500
++++ tdb-1.0.6/tdbtool.c 2003-10-02 22:41:51.000000000 -0400
+@@ -169,22 +169,22 @@
+
+ static void help(void)
+ {
+- printf("
+-tdbtool:
+- create dbname : create a database
+- open dbname : open an existing database
+- erase : erase the database
+- dump dumpname : dump the database as strings
+- insert key data : insert a record
+- store key data : store a record (replace)
+- show key : show a record by key
+- delete key : delete a record by key
+- list : print the database hash table and freelist
+- free : print the database freelist
+- 1 | first : print the first record
+- n | next : print the next record
+- q | quit : terminate
+- \\n : repeat 'next' command
++ printf("\n\
++tdbtool:\n\
++ create dbname : create a database\n\
++ open dbname : open an existing database\n\
++ erase : erase the database\n\
++ dump dumpname : dump the database as strings\n\
++ insert key data : insert a record\n\
++ store key data : store a record (replace)\n\
++ show key : show a record by key\n\
++ delete key : delete a record by key\n\
++ list : print the database hash table and freelist\n\
++ free : print the database freelist\n\
++ 1 | first : print the first record\n\
++ n | next : print the next record\n\
++ q | quit : terminate\n\
++ \\n : repeat 'next' command\n\
+ ");
+ }
+
diff --git a/extra/tdb/tdb-1.0.6-no-gdbm.patch b/extra/tdb/tdb-1.0.6-no-gdbm.patch
new file mode 100644
index 00000000..0f470307
--- /dev/null
+++ b/extra/tdb/tdb-1.0.6-no-gdbm.patch
@@ -0,0 +1,16 @@
+gdbm is only used in tdbspeed and tdbtest which never get
+installed, so lets go ahead and force disable gdbm "support"
+
+http://bugs.gentoo.org/113824
+
+--- Makefile.in
++++ Makefile.in
+@@ -80,7 +80,7 @@
+ @BUILD_TDBTORTURE_TRUE@TDBTORTURE = tdbtorture
+ @BUILD_TDBTORTURE_FALSE@TDBTORTURE =
+
+-noinst_PROGRAMS = tdbspeed tdbiterate $(TDBTEST) $(TDBTORTURE)
++noinst_PROGRAMS = tdbiterate $(TDBTORTURE)
+ bin_PROGRAMS = tdbtool tdbdump
+
+ lib_LTLIBRARIES = libtdb.la