summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2009-04-02 22:23:29 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2009-04-02 22:23:29 +0000
commit81377f881e7765797d0ccd6f3a251fe5237730d1 (patch)
tree32a789a5061ecd89b88d30c0a79d3b276fb21532 /extra
parent5567fd44c6c009312c1cf0c84bda1456ef180989 (diff)
downloadaports-81377f881e7765797d0ccd6f3a251fe5237730d1.tar.bz2
aports-81377f881e7765797d0ccd6f3a251fe5237730d1.tar.xz
extra/diffutils: added install script to create busybox links when uninstalling.
Diffstat (limited to 'extra')
-rw-r--r--extra/diffutils/APKBUILD11
-rw-r--r--extra/diffutils/diffutils.post-deinstall2
2 files changed, 8 insertions, 5 deletions
diff --git a/extra/diffutils/APKBUILD b/extra/diffutils/APKBUILD
index 89be666f..5a917713 100644
--- a/extra/diffutils/APKBUILD
+++ b/extra/diffutils/APKBUILD
@@ -1,16 +1,16 @@
# Maintainer: Leonardo Arena <rnalrd@gmail.com>
pkgname=diffutils
pkgver=2.8.1
-pkgrel=0
+pkgrel=1
pkgdesc="Show differences among files"
subpackages="$pkgname-doc"
-arch=""
url="http://www.gnu.org/software/diffutils/"
license="GPL2"
depends="uclibc"
makedepends=""
-install=
-source="http://ftp.gnu.org/pub/gnu/diffutils/diffutils-2.8.1.tar.gz"
+install="$pkgname.post-deinstall"
+source="http://ftp.gnu.org/pub/gnu/diffutils/diffutils-2.8.1.tar.gz
+$install"
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -22,4 +22,5 @@ build() {
make check || return 1
make install DESTDIR=$pkgdir
}
-md5sums="71f9c5ae19b60608f6c7f162da86a428 diffutils-2.8.1.tar.gz"
+md5sums="71f9c5ae19b60608f6c7f162da86a428 diffutils-2.8.1.tar.gz
+e8da9a22c2389fe5e2846b8c0de45767 diffutils.post-deinstall"
diff --git a/extra/diffutils/diffutils.post-deinstall b/extra/diffutils/diffutils.post-deinstall
new file mode 100644
index 00000000..c59247ad
--- /dev/null
+++ b/extra/diffutils/diffutils.post-deinstall
@@ -0,0 +1,2 @@
+#!/bin/sh
+busybox --install -s