summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-31 08:37:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-31 08:37:37 +0000
commitfa0ac7841b991b65742ada13f1d0b1e785d08e9c (patch)
treeb1eb1dd204ff8334f87c60e6a900b0073214b352 /extra
parent4f01d1373bc57b55a9f3d0b3dd391f3c9b76b391 (diff)
downloadaports-fa0ac7841b991b65742ada13f1d0b1e785d08e9c.tar.bz2
aports-fa0ac7841b991b65742ada13f1d0b1e785d08e9c.tar.xz
extra/icu: new aport
International Components for Unicode library http://www.icu-project.org/
Diffstat (limited to 'extra')
-rw-r--r--extra/icu/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/extra/icu/APKBUILD b/extra/icu/APKBUILD
new file mode 100644
index 00000000..77fb93bf
--- /dev/null
+++ b/extra/icu/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=icu
+pkgver=4.1.3
+_ver=4_1_3
+pkgrel=0
+pkgdesc="International Components for Unicode library"
+url="http://www.icu-project.org/"
+license="custom:icu"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="uclibc++ uclibc libgcc"
+makedepends="uclibc++-dev"
+source="http://download.icu-project.org/files/icu4c/${pkgver%.*}/${pkgname}4c-$_ver-src.tgz"
+
+build ()
+{
+ cd "$srcdir"/icu/source
+ export CXX=g++-uc
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" install || return 1
+ chmod +x "$pkgdir"/usr/bin/icu-config
+ install -Dm644 "$srcdir"/icu/license.html \
+ "$pkgdir"/usr/share/licenses/icu/license.html
+}
+md5sums="c3c16d2731c9c5da9007cb6c9e4f1929 icu4c-4_1_3-src.tgz"