summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-27 14:37:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-27 14:37:00 +0000
commit07cad0c586af6ecca9eaf9297f3d9ebb7d884d44 (patch)
treef0c56f6287e1589607dabdc0dbf5fbfa4d7dd2b7 /extra
parent5e1d1da0427ff55f4e3c46a60d3739414b375183 (diff)
downloadaports-07cad0c586af6ecca9eaf9297f3d9ebb7d884d44.tar.bz2
aports-07cad0c586af6ecca9eaf9297f3d9ebb7d884d44.tar.xz
extra/bzip2: add post-deinstall script to restore busybox links
Diffstat (limited to 'extra')
-rw-r--r--extra/bzip2/APKBUILD12
-rw-r--r--extra/bzip2/bzip2.post-deinstall3
2 files changed, 13 insertions, 2 deletions
diff --git a/extra/bzip2/APKBUILD b/extra/bzip2/APKBUILD
index 491eefe1..09721bb7 100644
--- a/extra/bzip2/APKBUILD
+++ b/extra/bzip2/APKBUILD
@@ -1,11 +1,14 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bzip2
pkgver=1.0.5
-pkgrel=0
+pkgrel=1
pkgdesc="A high-quality data compression program"
url="http://sources.redhat.com/bzip2"
license="BZIP2"
depends="uclibc"
+install="$pkgname.post-deinstall"
source="http://www.bzip.org/$pkgver/$pkgname-$pkgver.tar.gz
+ $install
bzip2-1.0.4-POSIX-shell.patch
bzip2-1.0.4-makefile-CFLAGS.patch
bzip2-1.0.4-man-links.patch
@@ -37,4 +40,9 @@ build () {
make all || return 1
make PREFIX="$pkgdir"/usr install || return 1
}
-md5sums="3c15a0c8d1d3ee1c46a1634d00617b1a bzip2-1.0.5.tar.gz"
+md5sums="3c15a0c8d1d3ee1c46a1634d00617b1a bzip2-1.0.5.tar.gz
+b84506d253e04db3c5af9016fead45a3 bzip2.post-deinstall
+2e9bcfeb1614b55f5ba2d087ac65a3fe bzip2-1.0.4-POSIX-shell.patch
+56b90131e3c2ae425b758de9c7be7682 bzip2-1.0.4-makefile-CFLAGS.patch
+fd13ef6bc55276c7e3adc346bde56cd1 bzip2-1.0.4-man-links.patch
+643983e8134723ebe53c858b1a3938ad bzip2-1.0.4-saneso.patch"
diff --git a/extra/bzip2/bzip2.post-deinstall b/extra/bzip2/bzip2.post-deinstall
new file mode 100644
index 00000000..99b57c46
--- /dev/null
+++ b/extra/bzip2/bzip2.post-deinstall
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+busybox --install -s