summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-03-11 12:51:21 +0000
committerMichael Mason <ms13sp@gmail.com>2009-03-11 12:51:21 +0000
commitadf9a35af93a22a96dbb673e45e4415a07f596a4 (patch)
tree68c7a668ad676524b0ab4004a4dbcfa19fc23f7f /extra
parent8279802efddeaad8939fce9b0f92296bab912bc4 (diff)
parentcbea729393aa8736e529eeff8f34fab6a984fe3a (diff)
downloadaports-adf9a35af93a22a96dbb673e45e4415a07f596a4.tar.bz2
aports-adf9a35af93a22a96dbb673e45e4415a07f596a4.tar.xz
Merge branch 'master' of git://dev.alpinelinux.org/aports
Conflicts: extra/snort/APKBUILD testing/hypermail/APKBUILD
Diffstat (limited to 'extra')
-rw-r--r--extra/glib/APKBUILD13
-rw-r--r--extra/newt/APKBUILD35
-rw-r--r--extra/newt/newt-0.52.7-notcl.patch35
-rw-r--r--extra/popt/APKBUILD20
-rw-r--r--extra/slang/APKBUILD27
-rw-r--r--extra/slang/slang-2.1.3-uclibc.patch12
6 files changed, 139 insertions, 3 deletions
diff --git a/extra/glib/APKBUILD b/extra/glib/APKBUILD
index b0d5aa4e..dcc3d466 100644
--- a/extra/glib/APKBUILD
+++ b/extra/glib/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail.com>
pkgname=glib
-pkgver=2.18.3
+pkgver=2.18.4
pkgrel=0
pkgdesc="Common C routines used by Gtk+ and other libs"
url="http://www.gtk.org"
license='GPL'
depends="gettext libiconv"
makedepends="gettext-dev libiconv-dev pkgconfig"
-source="http://ftp.gnome.org/pub/gnome/sources/glib/2.18/glib-2.18.3.tar.bz2"
+source="http://ftp.gnome.org/pub/gnome/sources/glib/2.18/glib-$pkgver.tar.bz2"
subpackages="$pkgname-doc $pkgname-dev"
build() {
@@ -19,4 +19,11 @@ build() {
make DESTDIR="$pkgdir/" install
}
-md5sums="f13996a7bd57525d796a6593f26a7771 glib-2.18.3.tar.bz2"
+# move the stuff in /usr/bin to the glib-dev package
+dev() {
+ default_dev
+ depends="$depends perl"
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+md5sums="ec25ed261534d870141000ab73f1a2bf glib-2.18.4.tar.bz2"
diff --git a/extra/newt/APKBUILD b/extra/newt/APKBUILD
new file mode 100644
index 00000000..dc81b8b6
--- /dev/null
+++ b/extra/newt/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=newt
+pkgver=0.52.8
+pkgrel=0
+pkgdesc="Redhat's Newt windowing toolkit development files"
+url="http://www.redhat.com/"
+license="LGPL-2"
+depends="uclibc slang popt ncurses"
+makedepends="slang-dev popt-dev python-dev ncurses-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://distfiles.gentoo.org/distfiles/$pkgname-$pkgver.tar.gz
+ $pkgname-0.52.7-notcl.patch
+ "
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
+
+ sed -i -e 's:-lslang:-lslang -lncurses:g' \
+ -e 's:instroot:DESTDIR:g' Makefile.in || return 1
+
+ ./configure --prefix=/usr \
+ --without-gpm \
+ --without-tcl \
+ --disable-nls
+ make -j1 RPM_OPT_FLAGS="$CFLAGS" || return 1
+ # TODO: fix the make install target to not try install po files
+ make -j1 DESTDIR="$pkgdir" prefix="/usr" RPM_OPT_FLAGS="ERROR" install \
+ || true
+}
+md5sums="0daef93590e9b6fd3419c871e75f9fa7 newt-0.52.8.tar.gz
+6780156f3b66a3f05efe1ee821617031 newt-0.52.7-notcl.patch"
diff --git a/extra/newt/newt-0.52.7-notcl.patch b/extra/newt/newt-0.52.7-notcl.patch
new file mode 100644
index 00000000..b9f86e6b
--- /dev/null
+++ b/extra/newt/newt-0.52.7-notcl.patch
@@ -0,0 +1,35 @@
+--- newt-0.52.7/Makefile.in.orig 2008-01-15 16:57:12.000000000 +0100
++++ newt-0.52.7/Makefile.in 2008-01-15 16:58:38.000000000 +0100
+@@ -15,7 +15,7 @@
+ PYTHONVERS = @PYTHONVERS@
+ WHIPTCLSO = @WHIPTCLSO@
+
+-PROGS = test whiptail $(WHIPTCLSO) testgrid testtree showchars showkey
++PROGS = test whiptail testgrid testtree showchars showkey
+ TESTOBJS = test.o testgrid.o testtree.o showchars.o showkey.o
+ NDIALOGOBJS = whiptail.o dialogboxes.o
+ WHIPTCLOBJS = shared/whiptcl.o shared/dialogboxes.o
+@@ -78,9 +78,6 @@
+ whiptail: $(NDIALOGOBJS) $(LIBNEWTSH)
+ $(CC) -g -o whiptail $(NDIALOGOBJS) -L . -lnewt $(LIBS) -lpopt
+
+-whiptcl.so: $(WHIPTCLOBJS) $(LIBNEWTSH)
+- $(CC) -shared $(SHCFLAGS) -o whiptcl.so $(WHIPTCLOBJS) -L . -lnewt $(LIBTCL) -lslang -lpopt -lm
+-
+ $(LIBNEWT): $(LIBOBJS)
+ ar rv $@ $^
+
+@@ -120,12 +117,11 @@
+ install -m 644 whiptail.1 $(instroot)/$(man1dir)
+ make -C po datadir=$(instroot)/$(datadir) install
+
+-install-sh: sharedlib $(WHIPTCLSO) _snackmodule.so
++install-sh: sharedlib _snackmodule.so
+ [ -d $(instroot)/$(libdir) ] || install -m 755 -d $(instroot)/$(libdir)
+ install -m 755 $(LIBNEWTSH) $(instroot)/$(libdir)
+ ln -sf $(LIBNEWTSONAME) $(instroot)/$(libdir)/libnewt.so
+ ln -sf $(LIBNEWTSH) $(instroot)/$(libdir)/$(LIBNEWTSONAME)
+- [ -n "$(WHIPTCLSO)" ] && install -m 755 whiptcl.so $(instroot)/$(libdir) || :
+ for ver in $(PYTHONVERS) ; do \
+ [ -d $(instroot)/$(libdir)/$$ver/site-packages ] || install -m 755 -d $(instroot)/$(libdir)/$$ver/site-packages ;\
+ install -m 755 $$ver/_snackmodule.so $(instroot)/$(libdir)/$$ver/site-packages ;\
diff --git a/extra/popt/APKBUILD b/extra/popt/APKBUILD
new file mode 100644
index 00000000..4826bd2d
--- /dev/null
+++ b/extra/popt/APKBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=popt
+pkgver=1.14
+pkgrel=0
+pkgdesc="Parse Options - Command line parser"
+url="http://rpm5.org/"
+license="as-is"
+depends="uclibc"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://rpm5.org/files/popt/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --without-included-gettext \
+ --disable-nls || return 1
+ make || return 1
+ make install DESTDIR="$pkgdir"
+}
+md5sums="4f90a07316eb825604dd10ae4f9f3f04 popt-1.14.tar.gz"
diff --git a/extra/slang/APKBUILD b/extra/slang/APKBUILD
new file mode 100644
index 00000000..c1fe9620
--- /dev/null
+++ b/extra/slang/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=slang
+pkgver=2.1.4
+pkgrel=0
+pkgdesc="S-Lang is a powerful interpreted language"
+url="http://www.s-lang.org/"
+license="GPL"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="uclibc pcre"
+makedepends="pcre-dev"
+source="ftp://ftp.fu-berlin.de/pub/unix/misc/$pkgname/v2.1/$pkgname-$pkgver.tar.gz
+ slang-2.1.3-uclibc.patch
+ "
+
+build () {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc || return 1
+ make || return 1
+ make install-all DESTDIR="$pkgdir" || return 1
+}
+md5sums="3516f593bc04975844f26137c18275d2 slang-2.1.4.tar.gz
+56ca82f415578994b6050e769b6b7bc9 slang-2.1.3-uclibc.patch"
diff --git a/extra/slang/slang-2.1.3-uclibc.patch b/extra/slang/slang-2.1.3-uclibc.patch
new file mode 100644
index 00000000..d7ed5a8d
--- /dev/null
+++ b/extra/slang/slang-2.1.3-uclibc.patch
@@ -0,0 +1,12 @@
+diff -ur slang-2.1.3.orig/src/slcommon.c slang-2.1.3/src/slcommon.c
+--- slang-2.1.3.orig/src/slcommon.c 2007-01-10 18:09:07.000000000 +0200
++++ slang-2.1.3/src/slcommon.c 2008-03-19 16:09:09.000000000 +0200
+@@ -191,7 +191,7 @@
+ return p;
+ }
+
+-#if !defined(HAVE_ISSETUGID) && defined(__GLIBC__) && (__GLIBC__ >= 2)
++#if !defined(HAVE_ISSETUGID) && defined(__GLIBC__) && (__GLIBC__ >= 2) && !defined(__UCLIBC__)
+ extern int __libc_enable_secure;
+ # define HAVE___LIBC_ENABLE_SECURE 1
+ #endif