summaryrefslogtreecommitdiffstats
path: root/main/alpine-conf
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-11 21:01:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-11 21:01:14 +0000
commit6c09d61f517f20dd18137702692cf1fd64dbc644 (patch)
tree84f08052ecda32fea64a38513077fcfcfd999d0f /main/alpine-conf
parent67bd5d5d0fc6f7eb4b14dcbefa8a73adad050733 (diff)
downloadaports-6c09d61f517f20dd18137702692cf1fd64dbc644.tar.bz2
aports-6c09d61f517f20dd18137702692cf1fd64dbc644.tar.xz
main/alpine-conf: bugfix for lbu
lbu thought /media/usb was mounted when it was /media/usbdisk.
Diffstat (limited to 'main/alpine-conf')
-rw-r--r--main/alpine-conf/0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch27
-rw-r--r--main/alpine-conf/APKBUILD7
2 files changed, 32 insertions, 2 deletions
diff --git a/main/alpine-conf/0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch b/main/alpine-conf/0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch
new file mode 100644
index 00000000..858c3b81
--- /dev/null
+++ b/main/alpine-conf/0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch
@@ -0,0 +1,27 @@
+From dedf250425d3cb082cae9f0005d94fbc01e1e953 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 11 Jan 2010 20:56:02 +0000
+Subject: [PATCH] lbu: fix the way we check if a dir is mounted or not
+
+this works around an issue when lbu wrongly assumes /media/usb is
+mounted when /media/usbdisk is.
+---
+ lbu.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/lbu.in b/lbu.in
+index 7709567..da8ba86 100644
+--- a/lbu.in
++++ b/lbu.in
+@@ -65,7 +65,7 @@ exit_clean() {
+ }
+
+ mount_once() {
+- if ! grep $1 /proc/mounts >/dev/null; then
++ if awk "\$2 == \"$1\" {exit 1}" /proc/mounts; then
+ mount $1 && UMOUNT_LIST="$1 $UMOUNT_LIST"
+ fi
+ }
+--
+1.6.6
+
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index 9182c81b..902dd78d 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,16 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
pkgver=2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
depends="openrc"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ 0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch
"
license="GPL-2"
build() {
cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i "$srcdir"/0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch || return 1
make || return 1
make install PREFIX= DESTDIR="$pkgdir"
@@ -18,4 +20,5 @@ build() {
ln -s lbu "$pkgdir"/sbin/lbu_$i
done
}
-md5sums="0aa966ef854de61b375d7e08bdb105b4 alpine-conf-2.0.tar.bz2"
+md5sums="0aa966ef854de61b375d7e08bdb105b4 alpine-conf-2.0.tar.bz2
+3b520ebbf30e4e5c2ff76f14a1e2d8f2 0001-lbu-fix-the-way-we-check-if-a-dir-is-mounted-or-not.patch"