summaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-27 13:42:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-27 13:44:18 +0000
commit20b0d4bd9952f14fec20632503870d57d84a61e2 (patch)
tree9636596ac881ffecd7d0c7b93184d3bc883e20b1 /main/busybox
parentd85e87e8c70fb2d0da194636d83ef411daa1d0cc (diff)
downloadaports-20b0d4bd9952f14fec20632503870d57d84a61e2.tar.bz2
aports-20b0d4bd9952f14fec20632503870d57d84a61e2.tar.xz
main/busybox: include /var/cache/misc dir
busybox is most likely to be installed early in a clean install and the /var/cache/misc is needed for the post-install.
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 4b69c827..f7e331be 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.15.2
-pkgrel=0
+pkgrel=1
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license="GPL-2"
@@ -38,7 +38,8 @@ build() {
make silentoldconfig || return 1
make || return 1
make install DESTDIR="$pkgdir"
- mkdir -p "$pkgdir"/usr/sbin "$pkgdir"/usr/bin "$pkgdir"/tmp
+ mkdir -p "$pkgdir"/usr/sbin "$pkgdir"/usr/bin "$pkgdir"/tmp \
+ "$pkgdir"/var/cache/misc
chmod 1777 "$pkgdir"/tmp
# we need /bin/sh to be able to execute post-install
ln -s /bin/busybox "$pkgdir"/bin/sh