summaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-17 11:57:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-17 11:57:30 +0000
commit77daa2d2a662f693dd29d2592e3d36f1e3415b4c (patch)
treed0979be2e236222a95adbce376709bcffbbc2a98 /main/busybox
parent299cbbf9570c47636c7b122b59e8791253f77898 (diff)
downloadaports-77daa2d2a662f693dd29d2592e3d36f1e3415b4c.tar.bz2
aports-77daa2d2a662f693dd29d2592e3d36f1e3415b4c.tar.xz
Revert "main/busybox: use triggers in apk-tools"
We need the .post-install and .post-upgrade scripts early, otherwise we break installscripts for all packages installed after busybox. This reverts commit 13f7afcb44ab3fc34ab250aa7df135e1cb684cac.
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD5
-rw-r--r--main/busybox/busybox.post-install3
l---------main/busybox/busybox.post-upgrade1
-rw-r--r--main/busybox/busybox.trigger15
4 files changed, 6 insertions, 18 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 1ec62774..7e428e21 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,13 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.14.3
-pkgrel=2
+pkgrel=3
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license="GPL-2"
depends=
-install= #"$pkgname.post-install $pkgname.post-upgrade"
-triggers="busybox.trigger:/bin /usr/bin /sbin /usr/sbin /lib/modules/*"
+install="$pkgname.post-install $pkgname.post-upgrade"
source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
$pkgname-1.11.1-bb.patch
0001-install-compat-fix-for-mode-of-created-files.patch
diff --git a/main/busybox/busybox.post-install b/main/busybox/busybox.post-install
new file mode 100644
index 00000000..8baed730
--- /dev/null
+++ b/main/busybox/busybox.post-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/bin/busybox --install -s
diff --git a/main/busybox/busybox.post-upgrade b/main/busybox/busybox.post-upgrade
new file mode 120000
index 00000000..1f4b450e
--- /dev/null
+++ b/main/busybox/busybox.post-upgrade
@@ -0,0 +1 @@
+busybox.post-install \ No newline at end of file
diff --git a/main/busybox/busybox.trigger b/main/busybox/busybox.trigger
deleted file mode 100644
index 8bdef2ba..00000000
--- a/main/busybox/busybox.trigger
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-do_bb_install=
-
-for i in "$@"; do
- case "$i" in
- /lib/modules/*) /bin/busybox depmod ${i#/lib/modules/};;
- *) do_bb_install=yes;;
- esac
-done
-
-if [ -n "$do_bb_install" ]; then
- /bin/busybox --install -s
-fi
-