summaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-27 13:42:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-27 13:49:26 +0000
commitbbb76168d7ebb06e84daefc14ec0d01f119ea63a (patch)
treeda999a53b41c0da7c1a0ca6fbabafd843838ec9c /main/busybox
parent22ed998a755d7645f15f7c0bd21723ddd757c17e (diff)
downloadaports-bbb76168d7ebb06e84daefc14ec0d01f119ea63a.tar.bz2
aports-bbb76168d7ebb06e84daefc14ec0d01f119ea63a.tar.xz
main/busybox: include /var/cache/misc dir
busybox is most likely to be installed early in a clean install and the /var/cache/misc is needed for the post-install.
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 32e8fef5..c27783ff 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.14.4
-pkgrel=0
+pkgrel=1
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license="GPL-2"
@@ -44,7 +44,8 @@ build() {
make silentoldconfig || return 1
make || return 1
make install DESTDIR="$pkgdir"
- mkdir -p "$pkgdir"/usr/sbin "$pkgdir"/usr/bin "$pkgdir"/tmp
+ mkdir -p "$pkgdir"/usr/sbin "$pkgdir"/usr/bin "$pkgdir"/tmp \
+ "$pkgdir"/var/cache/misc
chmod 1777 "$pkgdir"/tmp
# we need /bin/sh to be able to execute post-install
ln -s /bin/busybox "$pkgdir"/bin/sh