summaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-03 03:44:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-03 03:44:53 +0000
commitbe91e4f7cf765bd8af1aa07c3ad2fec1079c02be (patch)
tree673f2136571975fea0624d0e229fa6a16ec24426 /main/busybox
parent06e8e02ce9068faaf3a6834bd48b3f9a4c5405d5 (diff)
downloadaports-be91e4f7cf765bd8af1aa07c3ad2fec1079c02be.tar.bz2
aports-be91e4f7cf765bd8af1aa07c3ad2fec1079c02be.tar.xz
main/busybox: upgrade to 1.14.3. backport install compat fix
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/0001-install-compat-fix-for-mode-of-created-files.patch40
-rw-r--r--main/busybox/APKBUILD14
-rw-r--r--main/busybox/busybox-1.14.2-df.patch134
-rw-r--r--main/busybox/busybox-1.14.2-ls.patch152
-rw-r--r--main/busybox/busybox-1.14.2-udhcpd.patch12
5 files changed, 45 insertions, 307 deletions
diff --git a/main/busybox/0001-install-compat-fix-for-mode-of-created-files.patch b/main/busybox/0001-install-compat-fix-for-mode-of-created-files.patch
new file mode 100644
index 00000000..a17ca235
--- /dev/null
+++ b/main/busybox/0001-install-compat-fix-for-mode-of-created-files.patch
@@ -0,0 +1,40 @@
+From 1f363a086779152ab04067e81484b8bb69e4af72 Mon Sep 17 00:00:00 2001
+From: Denys Vlasenko <vda.linux@googlemail.com>
+Date: Mon, 15 Jun 2009 18:13:51 +0200
+Subject: [PATCH] install: compat fix for mode of created files.
+
+By Mat Hostetter (mhostetter AT tilera.com)
+
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+---
+ coreutils/install.c | 7 ++++---
+ 1 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/coreutils/install.c b/coreutils/install.c
+index 24fb402..2e604be 100644
+--- a/coreutils/install.c
++++ b/coreutils/install.c
+@@ -129,7 +129,7 @@ int install_main(int argc, char **argv)
+ if (opts & OPT_PRESERVE_TIME) {
+ copy_flags |= FILEUTILS_PRESERVE_STATUS;
+ }
+- mode = 0666;
++ mode = 0755; /* GNU coreutils 6.10 compat */
+ if (opts & OPT_MODE)
+ bb_parse_mode(mode_str, &mode);
+ uid = (opts & OPT_OWNER) ? get_ug_id(uid_str, xuname2uid) : getuid();
+@@ -175,8 +175,9 @@ int install_main(int argc, char **argv)
+ }
+ }
+
+- /* Set the file mode */
+- if ((opts & OPT_MODE) && chmod(dest, mode) == -1) {
++ /* Set the file mode (always, not only with -m).
++ * GNU coreutils 6.10 is not affected by umask. */
++ if (chmod(dest, mode) == -1) {
+ bb_perror_msg("can't change %s of %s", "permissions", dest);
+ ret = EXIT_FAILURE;
+ }
+--
+1.6.3.3
+
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 94621bb4..3a5a6f87 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,17 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
-pkgver=1.14.2
-pkgrel=2
+pkgver=1.14.3
+pkgrel=0
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license="GPL-2"
depends=
install="$pkgname.post-install $pkgname.post-upgrade"
source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
- busybox-1.14.2-df.patch
- busybox-1.14.2-ls.patch
- busybox-1.14.2-udhcpd.patch
$pkgname-1.11.1-bb.patch
+ 0001-install-compat-fix-for-mode-of-created-files.patch
bb-tar-numeric-owner.patch
$install
busyboxconfig"
@@ -46,11 +44,9 @@ build() {
ln -s /bin/busybox "$pkgdir"/bin/sh
}
-md5sums="c13b09b4125688d5fca5c95a79bf814a busybox-1.14.2.tar.bz2
-a34c5e72c3f5308838ddc3bf70642136 busybox-1.14.2-df.patch
-b261df2f193bb97d8e3e59e02c957780 busybox-1.14.2-ls.patch
-ca9a77bd4f6000d2b031a2cee555fcd6 busybox-1.14.2-udhcpd.patch
+md5sums="d170bf5f97a41aec3a505eab690d5699 busybox-1.14.3.tar.bz2
4c0f3b486eaa0674961b7ddcd0c60a9b busybox-1.11.1-bb.patch
+73d39c57483084298c7e46bdbbbea8d1 0001-install-compat-fix-for-mode-of-created-files.patch
0b5b2d7db201f90cd08f4a3164ee29a1 bb-tar-numeric-owner.patch
56b78c358797cd15fb64719a48939267 busybox.post-install
56b78c358797cd15fb64719a48939267 busybox.post-upgrade
diff --git a/main/busybox/busybox-1.14.2-df.patch b/main/busybox/busybox-1.14.2-df.patch
deleted file mode 100644
index 7829f5fb..00000000
--- a/main/busybox/busybox-1.14.2-df.patch
+++ /dev/null
@@ -1,134 +0,0 @@
---- busybox-1.14.2/coreutils/df.c Sun Jul 5 22:59:28 2009
-+++ busybox-1.14.2-df/coreutils/df.c Sun Jul 5 23:00:09 2009
-@@ -44,7 +44,6 @@
- FILE *mount_table;
- struct mntent *mount_entry;
- struct statfs s;
-- static const char ignored_mounts[] ALIGN1 = "rootfs\0";
-
- enum {
- OPT_KILO = (1 << 0),
-@@ -120,7 +119,7 @@
- mount_point = *argv++;
- if (!mount_point)
- break;
-- mount_entry = find_mount_point(mount_point, bb_path_mtab_file);
-+ mount_entry = find_mount_point(mount_point);
- if (!mount_entry) {
- bb_error_msg("%s: can't find mount point", mount_point);
- set_error:
-@@ -154,8 +153,8 @@
- ) / (blocks_used + s.f_bavail);
- }
-
-- /* GNU coreutils 6.10 skip certain mounts, try to be compatible. */
-- if (index_in_strings(device, ignored_mounts) != -1)
-+ /* GNU coreutils 6.10 skips certain mounts, try to be compatible. */
-+ if (strcmp(device, "rootfs") == 0)
- continue;
-
- #ifdef WHY_WE_DO_IT_FOR_DEV_ROOT_ONLY
---- busybox-1.14.2/include/libbb.h Sun Jul 5 22:59:31 2009
-+++ busybox-1.14.2-df/include/libbb.h Sun Jul 5 23:00:09 2009
-@@ -1025,7 +1025,7 @@
-
- #ifdef HAVE_MNTENT_H
- extern int match_fstype(const struct mntent *mt, const char *fstypes) FAST_FUNC;
--extern struct mntent *find_mount_point(const char *name, const char *table) FAST_FUNC;
-+extern struct mntent *find_mount_point(const char *name) FAST_FUNC;
- #endif
- extern void erase_mtab(const char * name) FAST_FUNC;
- extern unsigned int tty_baud_to_value(speed_t speed) FAST_FUNC;
---- busybox-1.14.2/libbb/find_mount_point.c Sun Jul 5 22:59:24 2009
-+++ busybox-1.14.2-df/libbb/find_mount_point.c Sun Jul 5 23:00:09 2009
-@@ -17,7 +17,7 @@
- * Given any other file (or directory), find the mount table entry for its
- * filesystem.
- */
--struct mntent* FAST_FUNC find_mount_point(const char *name, const char *table)
-+struct mntent* FAST_FUNC find_mount_point(const char *name)
- {
- struct stat s;
- dev_t mountDevice;
-@@ -25,27 +25,35 @@
- struct mntent *mountEntry;
-
- if (stat(name, &s) != 0)
-- return 0;
-+ return NULL;
-
-- if ((s.st_mode & S_IFMT) == S_IFBLK)
-+ if (S_ISBLK(s.st_mode))
- mountDevice = s.st_rdev;
- else
- mountDevice = s.st_dev;
-
-
-- mountTable = setmntent(table ? table : bb_path_mtab_file, "r");
-+ mountTable = setmntent(bb_path_mtab_file, "r");
- if (!mountTable)
- return 0;
-
-- while ((mountEntry = getmntent(mountTable)) != 0) {
-+ while ((mountEntry = getmntent(mountTable)) != NULL) {
-+ /* rootfs mount in Linux 2.6 exists always,
-+ * and it makes sense to always ignore it.
-+ * Otherwise people can't reference their "real" root! */
-+ if (strcmp(mountEntry->mnt_fsname, "rootfs") == 0)
-+ continue;
-+
- if (strcmp(name, mountEntry->mnt_dir) == 0
- || strcmp(name, mountEntry->mnt_fsname) == 0
- ) { /* String match. */
- break;
- }
-- if (stat(mountEntry->mnt_fsname, &s) == 0 && s.st_rdev == mountDevice) /* Match the device. */
-+ /* Match the device. */
-+ if (stat(mountEntry->mnt_fsname, &s) == 0 && s.st_rdev == mountDevice)
- break;
-- if (stat(mountEntry->mnt_dir, &s) == 0 && s.st_dev == mountDevice) /* Match the directory's mount point. */
-+ /* Match the directory's mount point. */
-+ if (stat(mountEntry->mnt_dir, &s) == 0 && s.st_dev == mountDevice)
- break;
- }
- endmntent(mountTable);
---- busybox-1.14.2/util-linux/mkfs_minix.c Sun Jul 5 22:59:30 2009
-+++ busybox-1.14.2-df/util-linux/mkfs_minix.c Sun Jul 5 23:00:09 2009
-@@ -624,7 +624,6 @@
- int mkfs_minix_main(int argc, char **argv) MAIN_EXTERNALLY_VISIBLE;
- int mkfs_minix_main(int argc UNUSED_PARAM, char **argv)
- {
-- struct mntent *mp;
- unsigned opt;
- char *tmp;
- struct stat statbuf;
-@@ -683,11 +682,8 @@
- G.total_blocks = 65535;
-
- /* Check if it is mounted */
-- mp = find_mount_point(G.device_name, NULL);
-- if (mp && strcmp(G.device_name, mp->mnt_fsname) == 0)
-- bb_error_msg_and_die("%s is mounted on %s; "
-- "refusing to make a filesystem",
-- G.device_name, mp->mnt_dir);
-+ if (find_mount_point(G.device_name))
-+ bb_error_msg_and_die("can't format mounted filesystem");
-
- xmove_fd(xopen(G.device_name, O_RDWR), dev_fd);
- if (fstat(dev_fd, &statbuf) < 0)
---- busybox-1.14.2/util-linux/mkfs_vfat.c Sun Jul 5 22:59:30 2009
-+++ busybox-1.14.2-df/util-linux/mkfs_vfat.c Sun Jul 5 23:00:35 2009
-@@ -273,10 +273,10 @@
- device_num == 0x0d00 || // xd
- device_num == 0x1600 ) // hdc, hdd
- )
-- bb_error_msg_and_die("Will not try to make filesystem on full-disk device (use -I if wanted)");
-+ bb_error_msg_and_die("will not try to make filesystem on full-disk device (use -I if wanted)");
- // can't work on mounted filesystems
-- if (find_mount_point(device_name, NULL))
-- bb_error_msg_and_die("Can't format mounted filesystem");
-+ if (find_mount_point(device_name))
-+ bb_error_msg_and_die("can't format mounted filesystem");
- #endif
- // get true sector size
- // (parameter must be int*, not long* or size_t*)
diff --git a/main/busybox/busybox-1.14.2-ls.patch b/main/busybox/busybox-1.14.2-ls.patch
deleted file mode 100644
index 64e0a94f..00000000
--- a/main/busybox/busybox-1.14.2-ls.patch
+++ /dev/null
@@ -1,152 +0,0 @@
-diff -urpN busybox-1.14.2/coreutils/ls.c busybox-1.14.2-ls/coreutils/ls.c
---- busybox-1.14.2/coreutils/ls.c 2009-06-22 00:40:29.000000000 +0200
-+++ busybox-1.14.2-ls/coreutils/ls.c 2009-07-03 12:46:16.000000000 +0200
-@@ -144,8 +144,7 @@ static const char ls_options[] ALIGN1 =
- USE_FEATURE_LS_FOLLOWLINKS("L") /* 1, 24 */
- USE_FEATURE_LS_RECURSIVE("R") /* 1, 25 */
- USE_FEATURE_HUMAN_READABLE("h") /* 1, 26 */
-- USE_SELINUX("K") /* 1, 27 */
-- USE_SELINUX("Z") /* 1, 28 */
-+ USE_SELINUX("KZ") /* 2, 28 */
- USE_FEATURE_AUTOWIDTH("T:w:") /* 2, 30 */
- ;
- enum {
-@@ -162,6 +161,16 @@ enum {
- OPT_Q = (1 << 10),
- //OPT_A = (1 << 11),
- //OPT_k = (1 << 12),
-+ OPTBIT_color = 13
-+ + 4 * ENABLE_FEATURE_LS_TIMESTAMPS
-+ + 4 * ENABLE_FEATURE_LS_SORTFILES
-+ + 2 * ENABLE_FEATURE_LS_FILETYPES
-+ + 1 * ENABLE_FEATURE_LS_FOLLOWLINKS
-+ + 1 * ENABLE_FEATURE_LS_RECURSIVE
-+ + 1 * ENABLE_FEATURE_HUMAN_READABLE
-+ + 2 * ENABLE_SELINUX
-+ + 2 * ENABLE_FEATURE_AUTOWIDTH,
-+ OPT_color = 1 << OPTBIT_color,
- };
-
- enum {
-@@ -889,16 +898,6 @@ static int list_single(const struct dnod
- }
-
-
--/* colored LS support by JaWi, janwillem.janssen@lxtreme.nl */
--#if ENABLE_FEATURE_LS_COLOR
--/* long option entry used only for --color, which has no short option
-- * equivalent */
--static const char ls_color_opt[] ALIGN1 =
-- "color\0" Optional_argument "\xff" /* no short equivalent */
-- ;
--#endif
--
--
- int ls_main(int argc UNUSED_PARAM, char **argv)
- {
- struct dnode **dnd;
-@@ -911,8 +910,25 @@ int ls_main(int argc UNUSED_PARAM, char
- int dnfiles;
- int dndirs;
- int i;
-+#if ENABLE_FEATURE_LS_COLOR
-+ /* colored LS support by JaWi, janwillem.janssen@lxtreme.nl */
-+ /* coreutils 6.10:
-+ * # ls --color=BOGUS
-+ * ls: invalid argument 'BOGUS' for '--color'
-+ * Valid arguments are:
-+ * 'always', 'yes', 'force'
-+ * 'never', 'no', 'none'
-+ * 'auto', 'tty', 'if-tty'
-+ * (and substrings: "--color=alwa" work too)
-+ */
-+ static const char ls_longopts[] ALIGN1 =
-+ "color\0" Optional_argument "\xff"; /* no short equivalent */
-+ static const char color_str[] ALIGN1 =
-+ "always\0""yes\0""force\0"
-+ "auto\0""tty\0""if-tty\0";
- /* need to initialize since --color has _an optional_ argument */
-- USE_FEATURE_LS_COLOR(const char *color_opt = "always";)
-+ const char *color_opt = color_str; /* "always" */
-+#endif
-
- INIT_G();
-
-@@ -927,7 +943,7 @@ int ls_main(int argc UNUSED_PARAM, char
- #endif
-
- /* process options */
-- USE_FEATURE_LS_COLOR(applet_long_options = ls_color_opt;)
-+ USE_FEATURE_LS_COLOR(applet_long_options = ls_longopts;)
- #if ENABLE_FEATURE_AUTOWIDTH
- opt_complementary = "T+:w+"; /* -T N, -w N */
- opt = getopt32(argv, ls_options, &tabstops, &terminal_width
-@@ -966,13 +982,20 @@ int ls_main(int argc UNUSED_PARAM, char
- if (!p || (p[0] && strcmp(p, "none") != 0))
- show_color = 1;
- }
-- if (opt & (1 << i)) { /* next flag after short options */
-- if (strcmp("always", color_opt) == 0)
-- show_color = 1;
-- else if (strcmp("never", color_opt) == 0)
-+ if (opt & OPT_color) {
-+ if (color_opt[0] == 'n')
- show_color = 0;
-- else if (strcmp("auto", color_opt) == 0 && isatty(STDOUT_FILENO))
-- show_color = 1;
-+ else switch (index_in_substrings(color_str, color_opt)) {
-+ case 3:
-+ case 4:
-+ case 5:
-+ if (isatty(STDOUT_FILENO)) {
-+ case 0:
-+ case 1:
-+ case 2:
-+ show_color = 1;
-+ }
-+ }
- }
- #endif
-
-diff -urpN busybox-1.14.2/testsuite/ls/ls-1-works busybox-1.14.2-ls/testsuite/ls/ls-1-works
---- busybox-1.14.2/testsuite/ls/ls-1-works 2009-06-22 00:32:00.000000000 +0200
-+++ busybox-1.14.2-ls/testsuite/ls/ls-1-works 2009-07-02 14:28:45.000000000 +0200
-@@ -1,4 +1,4 @@
- [ -n "$d" ] || d=..
--ls -1 "$d" > logfile.gnu
--busybox ls -1 "$d" > logfile.bb
--cmp logfile.gnu logfile.bb
-+LC_ALL=C ls -1 "$d" > logfile.gnu
-+LC_ALL=C busybox ls -1 "$d" > logfile.bb
-+diff -ubw logfile.gnu logfile.bb
-diff -urpN busybox-1.14.2/testsuite/ls/ls-h-works busybox-1.14.2-ls/testsuite/ls/ls-h-works
---- busybox-1.14.2/testsuite/ls/ls-h-works 2009-06-22 00:32:00.000000000 +0200
-+++ busybox-1.14.2-ls/testsuite/ls/ls-h-works 2009-07-02 14:28:45.000000000 +0200
-@@ -1,4 +1,4 @@
- [ -n "$d" ] || d=..
--ls -h "$d" > logfile.gnu
--busybox ls -h "$d" > logfile.bb
--cmp logfile.gnu logfile.bb
-+LC_ALL=C ls -h "$d" > logfile.gnu
-+LC_ALL=C busybox ls -h "$d" > logfile.bb
-+diff -ubw logfile.gnu logfile.bb
-diff -urpN busybox-1.14.2/testsuite/ls/ls-l-works busybox-1.14.2-ls/testsuite/ls/ls-l-works
---- busybox-1.14.2/testsuite/ls/ls-l-works 2009-06-22 00:32:00.000000000 +0200
-+++ busybox-1.14.2-ls/testsuite/ls/ls-l-works 2009-07-02 14:28:45.000000000 +0200
-@@ -1,4 +1,4 @@
- [ -n "$d" ] || d=..
- LC_ALL=C ls -l "$d" > logfile.gnu
--busybox ls -l "$d" > logfile.bb
--diff -w logfile.gnu logfile.bb
-+LC_ALL=C busybox ls -l "$d" > logfile.bb
-+diff -ubw logfile.gnu logfile.bb
-diff -urpN busybox-1.14.2/testsuite/ls/ls-s-works busybox-1.14.2-ls/testsuite/ls/ls-s-works
---- busybox-1.14.2/testsuite/ls/ls-s-works 2009-06-22 00:32:00.000000000 +0200
-+++ busybox-1.14.2-ls/testsuite/ls/ls-s-works 2009-07-02 14:28:45.000000000 +0200
-@@ -1,4 +1,4 @@
- [ -n "$d" ] || d=..
- LC_ALL=C ls -1s "$d" > logfile.gnu
--busybox ls -1s "$d" > logfile.bb
--cmp logfile.gnu logfile.bb
-+LC_ALL=C busybox ls -1s "$d" > logfile.bb
-+diff -ubw logfile.gnu logfile.bb
diff --git a/main/busybox/busybox-1.14.2-udhcpd.patch b/main/busybox/busybox-1.14.2-udhcpd.patch
deleted file mode 100644
index a1502b41..00000000
--- a/main/busybox/busybox-1.14.2-udhcpd.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urpN busybox-1.14.2/networking/udhcp/files.c busybox-1.14.2-udhcpd/networking/udhcp/files.c
---- busybox-1.14.2/networking/udhcp/files.c 2009-06-22 00:40:29.000000000 +0200
-+++ busybox-1.14.2-udhcpd/networking/udhcp/files.c 2009-07-07 14:58:39.000000000 +0200
-@@ -420,7 +420,7 @@ void FAST_FUNC read_leases(const char *f
- continue;
- /* NB: add_lease takes "relative time", IOW,
- * lease duration, not lease deadline. */
-- if (!(add_lease(lease.chaddr, lease.yiaddr, expires, lease.hostname))) {
-+ if (!(add_lease(lease.chaddr, lease.yiaddr, expires, NULL /* was lease.hostname. bug in add_lease, disabled */ ))) {
- bb_error_msg("too many leases while loading %s", file);
- break;
- }