summaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-18 19:46:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-18 19:46:42 +0000
commitd03ad6f9292bdc62226897db4c93e9a435cbe2f7 (patch)
tree2fdf145f4fe92eb09db971daec09bbd8339ba291 /main/busybox
parent87cb1f87cd52daa595ca92846082ec01e44db64a (diff)
downloadaports-d03ad6f9292bdc62226897db4c93e9a435cbe2f7.tar.bz2
aports-d03ad6f9292bdc62226897db4c93e9a435cbe2f7.tar.xz
main/busybox: we need both .post-install and trigger
fixes #128
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD3
-rw-r--r--main/busybox/busybox.trigger15
2 files changed, 17 insertions, 1 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 7e428e21..7fb318c1 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,12 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.14.3
-pkgrel=3
+pkgrel=4
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license="GPL-2"
depends=
install="$pkgname.post-install $pkgname.post-upgrade"
+triggers="busybox.trigger:/bin /usr/bin /sbin /usr/sbin /lib/modules/*"
source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
$pkgname-1.11.1-bb.patch
0001-install-compat-fix-for-mode-of-created-files.patch
diff --git a/main/busybox/busybox.trigger b/main/busybox/busybox.trigger
new file mode 100644
index 00000000..8bdef2ba
--- /dev/null
+++ b/main/busybox/busybox.trigger
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+do_bb_install=
+
+for i in "$@"; do
+ case "$i" in
+ /lib/modules/*) /bin/busybox depmod ${i#/lib/modules/};;
+ *) do_bb_install=yes;;
+ esac
+done
+
+if [ -n "$do_bb_install" ]; then
+ /bin/busybox --install -s
+fi
+