summaryrefslogtreecommitdiffstats
path: root/main/file/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
commit2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd (patch)
treea63d3b3b1c89018b5419358eed5c2bb0acf1cd92 /main/file/APKBUILD
parente374901731eb35599bd6735de4dd38560e3a79b8 (diff)
downloadaports-2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd.tar.bz2
aports-2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd.tar.xz
move core/* to main/
added maintainer to several packages as well
Diffstat (limited to 'main/file/APKBUILD')
-rw-r--r--main/file/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/file/APKBUILD b/main/file/APKBUILD
new file mode 100644
index 00000000..7754f6ce
--- /dev/null
+++ b/main/file/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=file
+pkgver=5.03
+pkgrel=0
+pkgdesc="File type identification utility"
+url="http://www.darwinsys.com/file/"
+license="custom"
+depends="uclibc zlib"
+source="ftp://ftp.astron.com/pub/file/file-$pkgver.tar.gz
+ nocxx.patch"
+subpackages="$pkgname-dev $pkgname-doc"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ patch configure < ../nocxx.patch || return 1
+ ./configure --prefix=/usr --datadir=/usr/share/misc
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums="d05f08a53e5c2f51f8ee6a4758c0cc53 file-5.03.tar.gz
+28513788ba4d556ccd538867dc6205ab nocxx.patch"