summaryrefslogtreecommitdiffstats
path: root/main/git
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-09 14:57:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-09 14:57:59 +0000
commit5ff6b4381025d1adb77fff25e7a0710b9c9e528a (patch)
tree8dc0fe075d60f15555bdbd49093297182da07ab8 /main/git
parent827c781de93d46d6d9dc32524cc40a76948e665d (diff)
downloadaports-5ff6b4381025d1adb77fff25e7a0710b9c9e528a.tar.bz2
aports-5ff6b4381025d1adb77fff25e7a0710b9c9e528a.tar.xz
main/git: build fix
we actually need that busybox tar patch
Diffstat (limited to 'main/git')
-rw-r--r--main/git/APKBUILD3
-rw-r--r--main/git/bb-tar.patch8
2 files changed, 6 insertions, 5 deletions
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index c96f4044..919f9229 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -19,6 +19,7 @@ _makeopts="NO_ICONV=YesPlease
build () {
cd $srcdir/$pkgname-$pkgver
+ patch -p1 -i ../bb-tar.patch || return 1
make prefix=/usr DESTDIR="$pkgdir" $_makeopts || return 1
}
@@ -42,4 +43,4 @@ perl() {
md5sums="99708c449b23433136dbdfa38bd16d80 git-1.6.5.2.tar.bz2
-04e1bdf76a0bac568f8488daad07dce7 bb-tar.patch"
+e63a201556c4f089de790805c09a2e5b bb-tar.patch"
diff --git a/main/git/bb-tar.patch b/main/git/bb-tar.patch
index 0f15de5d..6acfa991 100644
--- a/main/git/bb-tar.patch
+++ b/main/git/bb-tar.patch
@@ -1,8 +1,8 @@
---- git-1.6.0.4/templates/Makefile.orig Mon Nov 10 17:10:51 2008
-+++ git-1.6.0.4/templates/Makefile Mon Nov 10 17:11:25 2008
+--- a/templates/Makefile Mon Oct 26 02:57:33 2009
++++ b/templates/Makefile Mon Nov 9 14:56:27 2009
@@ -50,4 +50,4 @@
install: all
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(template_instdir_SQ)'
(cd blt && $(TAR) cf - .) | \
-- (cd '$(DESTDIR_SQ)$(template_instdir_SQ)' && umask 022 && $(TAR) xfo -)
-+ (cd '$(DESTDIR_SQ)$(template_instdir_SQ)' && umask 022 && $(TAR) x)
+- (cd '$(DESTDIR_SQ)$(template_instdir_SQ)' && umask 022 && $(TAR) xof -)
++ (cd '$(DESTDIR_SQ)$(template_instdir_SQ)' && umask 022 && $(TAR) xf -)