summaryrefslogtreecommitdiffstats
path: root/main/git
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-09 14:33:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-09 14:33:12 +0000
commit27d5a4ac9ca3afa6de3db6227876bb815aad0587 (patch)
treecbd226a8c736d0d63d908aeedef94f28630b5be5 /main/git
parente199e241f67f874a03421a6c445026f2150df790 (diff)
downloadaports-27d5a4ac9ca3afa6de3db6227876bb815aad0587.tar.bz2
aports-27d5a4ac9ca3afa6de3db6227876bb815aad0587.tar.xz
main/git: upgrade to 1.6.5.2
Diffstat (limited to 'main/git')
-rw-r--r--main/git/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index dbf5a3c2..c96f4044 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=git
-pkgver=1.6.5
+pkgver=1.6.5.2
pkgrel=0
pkgdesc="GIT - the stupid content tracker"
url="http://git.or.cz/"
@@ -12,17 +12,19 @@ source="http://kernel.org/pub/software/scm/git/git-$pkgver.tar.bz2
bb-tar.patch
"
-build () {
- local makeopts="NO_ICONV=YesPlease
- NO_NSEC=YesPlease
- NO_TCLTK=YesPlease
- NO_SVN_TESTS=YesPlease"
+_makeopts="NO_ICONV=YesPlease
+ NO_NSEC=YesPlease
+ NO_TCLTK=YesPlease
+ NO_SVN_TESTS=YesPlease"
+build () {
cd $srcdir/$pkgname-$pkgver
- patch -p1 < ../bb-tar.patch || return 1
+ make prefix=/usr DESTDIR="$pkgdir" $_makeopts || return 1
+}
- make prefix=/usr DESTDIR="$pkgdir" $makeopts || return 1
- make prefix=/usr DESTDIR="$pkgdir" $makeopts install
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make prefix=/usr DESTDIR="$pkgdir" $_makeopts install
}
perl() {
@@ -39,5 +41,5 @@ perl() {
}
-md5sums="da86c1736c55edb9f446828581137b51 git-1.6.5.tar.bz2
+md5sums="99708c449b23433136dbdfa38bd16d80 git-1.6.5.2.tar.bz2
04e1bdf76a0bac568f8488daad07dce7 bb-tar.patch"