summaryrefslogtreecommitdiffstats
path: root/main/hunspell
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
commitb70981b68efcce5256eb11c6cd26ae123b10b6ea (patch)
treea38be6efae5e2ba15c2e839504632f9b7bfd5f91 /main/hunspell
parent2b4df81538b8398442d5296650905c70341dd8d3 (diff)
downloadaports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.bz2
aports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.xz
moved extra/* to main/
and fixed misc build issues
Diffstat (limited to 'main/hunspell')
-rw-r--r--main/hunspell/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/main/hunspell/APKBUILD b/main/hunspell/APKBUILD
new file mode 100644
index 00000000..6883855a
--- /dev/null
+++ b/main/hunspell/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=hunspell
+pkgver=1.2.8
+pkgrel=0
+pkgdesc="Spell checker and morphological analyzer library and program"
+url="http://hunspell.sourceforge.net/"
+license="GPL LGPL MPL"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="libgcc uclibc++"
+makedepends="uclibc++-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir/hunspell-$pkgver"
+ export CXX="${CXX_UC:-g++-uc}"
+
+ ./configure --prefix=/usr --disable-static || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ rm -rf "$pkgdir"/usr/share/locale/locale.alias
+}
+md5sums="1177af54a09e320d2c24015f29c3a93e hunspell-1.2.8.tar.gz"