summaryrefslogtreecommitdiffstats
path: root/main/lighttpd/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-17 12:16:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-17 12:23:08 +0000
commit65595048ad399d736e296201aaced08c6b0cb8e0 (patch)
tree25b94baf20c26a775f586263d93a26bfc836cf26 /main/lighttpd/APKBUILD
parentd2e0f3a8cc9e5c0dda76a2fd7aaddad0fd07f38e (diff)
downloadaports-65595048ad399d736e296201aaced08c6b0cb8e0.tar.bz2
aports-65595048ad399d736e296201aaced08c6b0cb8e0.tar.xz
main/lighttpd: fix handling of SSL_CTX_set_options() return value
fixes #329 (cherry picked from commit 192b8fad759488bbe2fea1b43acda638eb6ebe85)
Diffstat (limited to 'main/lighttpd/APKBUILD')
-rw-r--r--main/lighttpd/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/main/lighttpd/APKBUILD b/main/lighttpd/APKBUILD
index b70b4b55..44125b0e 100644
--- a/main/lighttpd/APKBUILD
+++ b/main/lighttpd/APKBUILD
@@ -2,7 +2,7 @@
pkgname=lighttpd
pkgver=1.4.26
_streamver=2.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="a secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
license="custom"
@@ -22,14 +22,18 @@ source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.ta
mod_cgi.conf
mod_fastcgi.conf
lighttpd-version-from-git.patch
+ fix-handling-return-value-of-SSL_CTX_set_options.patch
"
subpackages="$pkgname-dev $pkgname-doc $pkgname-h264_streaming"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
- # 323
- patch -p0 -i "$srcdir"/lighttpd-version-from-git.patch || return 0
+ # http://bugs.alpinelinux.org/issues/323
+ patch -p0 -i "$srcdir"/lighttpd-version-from-git.patch || return 1
+
+ # http://bugs.alpinelinux.org/issues/329
+ patch -p2 -i "$srcdir"/fix-handling-return-value-of-SSL_CTX_set_options.patch || return 1
# copy over the mod-h264-streaming mod
# http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Lighttpd-Version2#DownloadLighttpd1.4.191.4.20andother1.4.x
@@ -116,4 +120,5 @@ df5b2360ea380d988bf16905ab214286 lighttpd.conf
fef397e7bcf1b741dea211a555e1803c mime-types.conf
9c1407e95f62ed22da66c4ef5f69c3b5 mod_cgi.conf
f3363e39832f1b6678468b482d121afb mod_fastcgi.conf
-c2471f50eec2ce85da6dfaf8289725bc lighttpd-version-from-git.patch"
+c2471f50eec2ce85da6dfaf8289725bc lighttpd-version-from-git.patch
+770baaa9a8dae51e25db29d3561d5b76 fix-handling-return-value-of-SSL_CTX_set_options.patch"