summaryrefslogtreecommitdiffstats
path: root/main/linux-headers/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-06 10:46:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-06 10:46:29 +0000
commit1596e9266586fb64e63dbcf3a9bcacbe3b49391c (patch)
tree2a42ebe6c063af44ca38cfc6e52be9bd3fd4fdff /main/linux-headers/APKBUILD
parent3c9381442cb2cf40402d98e863cfe19ccb83d1a0 (diff)
downloadaports-1596e9266586fb64e63dbcf3a9bcacbe3b49391c.tar.bz2
aports-1596e9266586fb64e63dbcf3a9bcacbe3b49391c.tar.xz
main/linux-headers: fix issues with transition of scsi.h
Diffstat (limited to 'main/linux-headers/APKBUILD')
-rw-r--r--main/linux-headers/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/main/linux-headers/APKBUILD b/main/linux-headers/APKBUILD
index fce56c75..2dce2901 100644
--- a/main/linux-headers/APKBUILD
+++ b/main/linux-headers/APKBUILD
@@ -2,7 +2,7 @@
pkgname=linux-headers
pkgver=2.6.32.2
_kernver=2.6.32
-pkgrel=0
+pkgrel=1
pkgdesc="Linux system headers"
url="http://kernel.org"
license='GPL-2'
@@ -11,6 +11,7 @@ replaces="uclibc-dev"
options="!strip !tracedeps"
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
+ scsi.patch
"
build() {
@@ -18,6 +19,7 @@ build() {
if [ "$_kernver" != "$pkgver" ]; then
bunzip2 -c < ../patch-$pkgver.bz2 | patch -p1 || return 1
fi
+ patch -p1 -i "$srcdir"/scsi.patch || return 1
mkdir -p "$pkgdir/usr"
make headers_install INSTALL_HDR_PATH="$pkgdir/usr"
@@ -30,4 +32,5 @@ build() {
}
md5sums="260551284ac224c3a43c4adac7df4879 linux-2.6.32.tar.bz2
-924b7aa0fcd6e54c12ecc9b3c3082f59 patch-2.6.32.2.bz2"
+924b7aa0fcd6e54c12ecc9b3c3082f59 patch-2.6.32.2.bz2
+b6d05566fcfe07770d9386f0588f8758 scsi.patch"