summaryrefslogtreecommitdiffstats
path: root/main/lua-posix
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-07 16:58:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-07 16:58:14 +0000
commit99b468e9e2929212cd7c4a98ae1d958e35664385 (patch)
treec7798249f8e35e68f34d8bc545856d9476a7833f /main/lua-posix
parent110a0d168c5d5e378858880d2632f48f9bda1525 (diff)
downloadaports-99b468e9e2929212cd7c4a98ae1d958e35664385.tar.bz2
aports-99b468e9e2929212cd7c4a98ae1d958e35664385.tar.xz
main/lua-posix: renamed from luaposix
Diffstat (limited to 'main/lua-posix')
-rw-r--r--main/lua-posix/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/lua-posix/APKBUILD b/main/lua-posix/APKBUILD
new file mode 100644
index 00000000..bb90a0c8
--- /dev/null
+++ b/main/lua-posix/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-posix
+_name=luaposix
+pkgver=5.1.4
+pkgrel=0
+pkgdesc="POSIX library for Lua"
+url="http://luaforge.net/projects/luaposix/"
+license="MIT"
+depends="lua"
+makedepends="lua-dev"
+source="http://luaforge.net/frs/download.php/3572/luaposix-$pkgver.tar.gz"
+replaces="luaposix"
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ make PREFIX=/usr || return 1
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+md5sums="073019b1a52bfddb94e2521553b47ef5 luaposix-5.1.4.tar.gz"