summaryrefslogtreecommitdiffstats
path: root/main/lua-sql-postgres
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-07 17:28:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-07 17:28:28 +0000
commitec23be96602484fa5045dd0cde489bb189e4f3c7 (patch)
tree02bc5aa194bd440525dc0cecda4c0da5a5e1a134 /main/lua-sql-postgres
parentc5e33820f9e0f7c297492c1e8c23b7e75dfd16a1 (diff)
downloadaports-ec23be96602484fa5045dd0cde489bb189e4f3c7.tar.bz2
aports-ec23be96602484fa5045dd0cde489bb189e4f3c7.tar.xz
main/lua-sql-postgres: renamed from luasql-postgres
Diffstat (limited to 'main/lua-sql-postgres')
-rw-r--r--main/lua-sql-postgres/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/main/lua-sql-postgres/APKBUILD b/main/lua-sql-postgres/APKBUILD
new file mode 100644
index 00000000..08eb9d96
--- /dev/null
+++ b/main/lua-sql-postgres/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: Mika Havela <mika.havela@gmail.com>
+pkgname=lua-sql-postgres
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="PostgreSQL driver for LuaSQL"
+url="http://www.keplerproject.org/luasql/"
+license="MIT"
+depends="lua"
+makedepends="lua-dev postgresql-dev"
+install=
+subpackages=
+source="http://luaforge.net/frs/download.php/2686/luasql-$pkgver.tar.gz"
+replaces=luasql-postgres
+
+build() {
+ cd "$srcdir/luasql-$pkgver"
+ make CFLAGS="$CFLAGS" T=postgres DRIVER_LIBS="-lpq" || return 1
+}
+
+package() {
+ cd "$srcdir/luasql-$pkgver"
+ install -D src/postgres.so "$pkgdir"/usr/lib/lua/5.1/luasql/postgres.so
+}
+
+md5sums="63bdd57de4b9d1be336ba112d8cb69eb luasql-2.1.1.tar.gz"