summaryrefslogtreecommitdiffstats
path: root/main/parted
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
commit2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd (patch)
treea63d3b3b1c89018b5419358eed5c2bb0acf1cd92 /main/parted
parente374901731eb35599bd6735de4dd38560e3a79b8 (diff)
downloadaports-2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd.tar.bz2
aports-2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd.tar.xz
move core/* to main/
added maintainer to several packages as well
Diffstat (limited to 'main/parted')
-rw-r--r--main/parted/APKBUILD27
-rw-r--r--main/parted/nocxx.patch15
2 files changed, 42 insertions, 0 deletions
diff --git a/main/parted/APKBUILD b/main/parted/APKBUILD
new file mode 100644
index 00000000..a606b757
--- /dev/null
+++ b/main/parted/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=parted
+pkgver=1.8.8
+pkgrel=1
+pkgdesc="Utility to create, destroy, resize, check and copy partitions"
+url="http://www.gnu.org/software/parted/parted.html"
+license="GPL3"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="pkgconfig e2fsprogs-dev readline-dev ncurses-dev"
+source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ nocxx.patch"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ patch configure < ../nocxx.patch || return 1
+
+ ./configure --prefix=/usr \
+ --disable-debug \
+ --disable-nls \
+ --disable-Werror
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums="0d494591731082ec57cc18627728124a parted-1.8.8.tar.gz
+28513788ba4d556ccd538867dc6205ab nocxx.patch"
diff --git a/main/parted/nocxx.patch b/main/parted/nocxx.patch
new file mode 100644
index 00000000..beb1ab90
--- /dev/null
+++ b/main/parted/nocxx.patch
@@ -0,0 +1,15 @@
+--- a/configure 2004-12-07 21:34:23.205172545 +0000
++++ b/configure 2004-12-07 21:37:17.726654782 +0000
+@@ -5148,10 +5148,8 @@
+ :
+ else
+ { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&5;}
++ { echo "C++ sucks, ignoring ..." >&5; }; }
+ fi
+
+ ac_ext=cc