summaryrefslogtreecommitdiffstats
path: root/main/perl-digest-hmac
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-10 12:53:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-10 12:53:17 +0000
commit3ce1ef19f96e30aa0a86d1518abf42e241e37a1c (patch)
tree942984547a01ba5a324a6b0080017a6f92fb36ae /main/perl-digest-hmac
parentb244a4f0e220b0569ef00987113369325eea2d27 (diff)
downloadaports-3ce1ef19f96e30aa0a86d1518abf42e241e37a1c.tar.bz2
aports-3ce1ef19f96e30aa0a86d1518abf42e241e37a1c.tar.xz
main/perl-digest-hmac: new aport
Keyed-Hashing for Message Authentication Perl module http://search.cpan.org/~gaas/Digest-HMAC-1.01/
Diffstat (limited to 'main/perl-digest-hmac')
-rw-r--r--main/perl-digest-hmac/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/main/perl-digest-hmac/APKBUILD b/main/perl-digest-hmac/APKBUILD
new file mode 100644
index 00000000..f9538dc0
--- /dev/null
+++ b/main/perl-digest-hmac/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-digest-hmac
+_realname=Digest-HMAC
+pkgver=1.01
+pkgrel=0
+pkgdesc="Keyed-Hashing for Message Authentication Perl module"
+url="http://search.cpan.org/~gaas/Digest-HMAC-1.01/"
+license="GPL PerlArtistic"
+depends="perl perl-digest-sha1"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="32dc54c765100c638b5d7f7ff4c5c626 Digest-HMAC-1.01.tar.gz"