summaryrefslogtreecommitdiffstats
path: root/main/php
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-12 13:29:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-12 13:29:37 +0000
commit9881efaf35fb10a9145a18d71f9af6f019ccab81 (patch)
treec9f2c43d939bbedba9771100accbc622964a9c49 /main/php
parent33e57ec4e7664ef530bededfda2a7e09de9baa19 (diff)
downloadaports-9881efaf35fb10a9145a18d71f9af6f019ccab81.tar.bz2
aports-9881efaf35fb10a9145a18d71f9af6f019ccab81.tar.xz
main/php: explicit link to pthread
fixes #183
Diffstat (limited to 'main/php')
-rw-r--r--main/php/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/php/APKBUILD b/main/php/APKBUILD
index f5d971a5..a43bd2eb 100644
--- a/main/php/APKBUILD
+++ b/main/php/APKBUILD
@@ -3,7 +3,7 @@
pkgname=php
pkgver=5.2.10
_suhosinver=${pkgver}-0.9.7
-pkgrel=3
+pkgrel=4
pkgdesc="The PHP language runtime engine"
url="http://www.php.net/"
license="PHP-3"
@@ -159,6 +159,9 @@ build() {
--with-pic \
$phpextensions
+ # see #183
+ sed -i -e '/^BUILD_CGI/s/$(LDFLAGS)/-lpthread $(LDFLAGS)/' Makefile
+
make || return 1
make -j1 INSTALL_ROOT="$pkgdir" install || return 1
# fix the extension_dir