summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-12 10:17:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-12 10:18:32 +0000
commit6c1a6fba67ad60c43a1c334c0cf689f62f1cf8dd (patch)
treeb434a8a237c0016e3f9cb16e361794f9f60b1de8 /main
parent48796ee803ae190c95c642a9de9e4480fed34abb (diff)
downloadaports-6c1a6fba67ad60c43a1c334c0cf689f62f1cf8dd.tar.bz2
aports-6c1a6fba67ad60c43a1c334c0cf689f62f1cf8dd.tar.xz
main/lighttpd: fix version number in lighttpd
It should not pick up the git describe string from aports fixes #323 (cherry picked from commit 2b27ee5db323d5c8a457f6683bee03e00e65f98a)
Diffstat (limited to 'main')
-rw-r--r--main/lighttpd/APKBUILD9
-rw-r--r--main/lighttpd/lighttpd-version-from-git.patch13
2 files changed, 20 insertions, 2 deletions
diff --git a/main/lighttpd/APKBUILD b/main/lighttpd/APKBUILD
index 939bc934..b70b4b55 100644
--- a/main/lighttpd/APKBUILD
+++ b/main/lighttpd/APKBUILD
@@ -2,7 +2,7 @@
pkgname=lighttpd
pkgver=1.4.26
_streamver=2.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="a secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
license="custom"
@@ -21,12 +21,16 @@ source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.ta
mime-types.conf
mod_cgi.conf
mod_fastcgi.conf
+ lighttpd-version-from-git.patch
"
subpackages="$pkgname-dev $pkgname-doc $pkgname-h264_streaming"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
+ # 323
+ patch -p0 -i "$srcdir"/lighttpd-version-from-git.patch || return 0
+
# copy over the mod-h264-streaming mod
# http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Lighttpd-Version2#DownloadLighttpd1.4.191.4.20andother1.4.x
cp "$srcdir"/lighttpd-1.4.18/src/moov.* src/
@@ -111,4 +115,5 @@ ad091c9157134890499f26d170352c9f lighttpd.logrotate
df5b2360ea380d988bf16905ab214286 lighttpd.conf
fef397e7bcf1b741dea211a555e1803c mime-types.conf
9c1407e95f62ed22da66c4ef5f69c3b5 mod_cgi.conf
-f3363e39832f1b6678468b482d121afb mod_fastcgi.conf"
+f3363e39832f1b6678468b482d121afb mod_fastcgi.conf
+c2471f50eec2ce85da6dfaf8289725bc lighttpd-version-from-git.patch"
diff --git a/main/lighttpd/lighttpd-version-from-git.patch b/main/lighttpd/lighttpd-version-from-git.patch
new file mode 100644
index 00000000..ae6407c4
--- /dev/null
+++ b/main/lighttpd/lighttpd-version-from-git.patch
@@ -0,0 +1,13 @@
+Index: src/Makefile.am
+===================================================================
+--- src/Makefile.am (revision 2717)
++++ src/Makefile.am (working copy)
+@@ -19,7 +19,7 @@
+ REVISION=""; \
+ fi; \
+ fi; \
+- if test -z "$$REVISION" -a -x "`which git`"; then \
++ if test -z "$$REVISION" -a -d "$(top_srcdir)/.git" -a -x "`which git`"; then \
+ REVISION="$$(cd "$(top_srcdir)"; LANG= LC_ALL=C git describe --always 2>/dev/null || echo)"; \
+ fi; \
+ if test -n "$$REVISION"; then \