summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-03 10:08:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-03 10:53:50 +0000
commit1d3cf6d0a11391394ede93a944fdf22fd3d2472f (patch)
treeb24a42879ea18a5a43995495c3f0e7f571292ffa /main
parentc86b5e759c3fbd2f84d1b2d6d975ede2f2513cda (diff)
downloadaports-1d3cf6d0a11391394ede93a944fdf22fd3d2472f.tar.bz2
aports-1d3cf6d0a11391394ede93a944fdf22fd3d2472f.tar.xz
main/minicom: moved from testing
(cherry picked from commit 49900c76bb6afaddf29553c0e8b9b7b4708a2122)
Diffstat (limited to 'main')
-rw-r--r--main/minicom/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/main/minicom/APKBUILD b/main/minicom/APKBUILD
new file mode 100644
index 00000000..c419a9dc
--- /dev/null
+++ b/main/minicom/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=minicom
+pkgver=2.3
+pkgrel=1
+pkgdesc="menu driven communications program for terminals"
+url="http://alioth.debian.org/projects/minicom"
+license="GPL"
+depends=
+makedepends="ncurses-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://alioth.debian.org/frs/download.php/2332/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --without-libintl-prefix
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="0ebe7a91898384ca906787cc4e2c3f25 minicom-2.3.tar.gz"