summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTimo Teras <timo.teras@iki.fi>2009-10-07 10:33:07 +0300
committerTimo Teras <timo.teras@iki.fi>2009-10-07 10:51:47 +0300
commit740cef6664153c9eaff1f11ec549bb3c6ea05adc (patch)
treeae2e9274bb9b60f6470055e1792f9a8ba985ad31 /main
parent25f1e109e654f01ee6156899b95c4fd6cbe80e1b (diff)
downloadaports-740cef6664153c9eaff1f11ec549bb3c6ea05adc.tar.bz2
aports-740cef6664153c9eaff1f11ec549bb3c6ea05adc.tar.xz
main/squid: update to 2.7.STABLE7
additionally add a patch that prevents modification of Content-Type header on If-Modified-Since request 304 replies. RFC says those replies are invalid, but some broken servers return bogus data anyway, so ignoring the reply fixes some issues. (cherry picked from commit c447b3590d5fb3500e9ee67936893091cf1d565a)
Diffstat (limited to 'main')
-rw-r--r--main/squid/APKBUILD11
-rw-r--r--main/squid/squid-2.7-ims-content-type.patch11
2 files changed, 18 insertions, 4 deletions
diff --git a/main/squid/APKBUILD b/main/squid/APKBUILD
index 01f7bfa7..66be7961 100644
--- a/main/squid/APKBUILD
+++ b/main/squid/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=squid
-pkgver=2.7.6
-_ver=2.7.STABLE6
-pkgrel=12
+pkgver=2.7.7
+_ver=2.7.STABLE7
+pkgrel=0
pkgdesc="A full-featured Web proxy cache server."
url="http://www.squid-cache.org"
install="squid.pre-install squid.pre-upgrade squid.post-install"
@@ -52,6 +52,7 @@ source="http://www.squid-cache.org/Versions/v2/2.7/${pkgname}-${_ver}.tar.bz2
squid.initd
squid.confd
squid-2.7-gentoo.patch
+ squid-2.7-ims-content-type.patch
$pkgname.logrotate
"
pkgusers="squid"
@@ -61,6 +62,7 @@ build() {
cd "$srcdir/$pkgname-$_ver"
patch -p1 -i "$srcdir"/squid-2.7-gentoo.patch || return 1
+ patch -p1 -i "$srcdir"/squid-2.7-ims-content-type.patch || return 1
touch NEWS AUTHORS
aclocal && autoconf && automake -a || return 1
@@ -278,8 +280,9 @@ errors_ukrainian_utf8() {
}
-md5sums="6de3a6a7a56a7ecae092f2d31a04f039 squid-2.7.STABLE6.tar.bz2
+md5sums="c18b0371fca813d5e7c7e0baf87baa22 squid-2.7.STABLE7.tar.bz2
57fed05adc40acab6a5480ec7a014154 squid.initd
44b052db7910f386ef88ddcf69c9ba4e squid.confd
3827f71d940b47eb385a1a1d92a51d66 squid-2.7-gentoo.patch
+549377b5a6b673bf19ea6c34003d122c squid-2.7-ims-content-type.patch
58823e0b86bc2dc71d270208b7b284b4 squid.logrotate"
diff --git a/main/squid/squid-2.7-ims-content-type.patch b/main/squid/squid-2.7-ims-content-type.patch
new file mode 100644
index 00000000..8b66197e
--- /dev/null
+++ b/main/squid/squid-2.7-ims-content-type.patch
@@ -0,0 +1,11 @@
+--- a/src/HttpReply.c.orig Wed Oct 7 07:08:08 2009
++++ b/src/HttpReply.c Wed Oct 7 07:08:20 2009
+@@ -43,7 +43,7 @@
+ static http_hdr_type Denied304HeadersArr[] =
+ {
+ HDR_CONTENT_ENCODING, HDR_CONTENT_LANGUAGE, HDR_CONTENT_LENGTH,
+- HDR_CONTENT_LOCATION, HDR_CONTENT_RANGE
++ HDR_CONTENT_LOCATION, HDR_CONTENT_RANGE, HDR_CONTENT_TYPE
+ };
+
+ /* local routines */